{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security.","exploited":"There is no known exploitation of GHSA-83x9-vc3c-hghc in the wild and no public exploit code.","fix":"Upgrade org.opensearch.plugin:opensearch-security to 2.19.0.0 or later.","what":"GHSA-83x9-vc3c-hghc is an authentication bypass vulnerability in org.opensearch.plugin:opensearch-security, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-83x9-vc3c-hghc and fix it if it is affected.\n\nWhat it is: GHSA-83x9-vc3c-hghc is an authentication bypass vulnerability in org.opensearch.plugin:opensearch-security, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-83x9-vc3c-hghc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.plugin:opensearch-security (Maven): affected from 2.11.0.0; fixed in 2.19.0.0\n- org.opensearch.plugin:opensearch-security (Maven): affected from 2.11.0.0; fixed in 2.19.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/ (Markdown: https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/index.md)","id":"GHSA-83x9-vc3c-hghc","markdown":"https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/index.md","name":"GHSA-83x9-vc3c-hghc","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenSearch server","requires_auth":"none","summary":"Attackers can bypass REST-layer authorization via malformed paths to access restricted endpoints in custom OpenSearch plugins.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Description\n\nA flaw was identified in the OpenSearch REST layer that could allow authorization checks to be bypassed when processing certain malformed HTTP requests. This could permit unauthorized access to restricted API endpoints in environments that rely on REST-layer authorization.\n\nTransport-level authorization is not affected by this issue.\n\n### Impact\n\nThe default OpenSearch distribution is not affected by this issue. REST actions in the default distribution have corresponding transport actions that independently enforce authorization. Custom plugins that register REST actions without a corresponding transport action may be affected, potentially allowing unauthorized read access to those endpoints.\n\n### Patches\n\nThis issue is fixed in OpenSearch 2.19.0. Users should upgrade to 2.19.0 or later.","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenSearch has a bypass of REST Layer Authorization Using Malformed Paths","id":"GHSA-83x9-vc3c-hghc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.19.0.0"],"introduced":["2.11.0.0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":null,"source":"GHSA-83x9-vc3c-hghc"},{"ecosystem":"Maven","fixed":["2.19.0.0"],"introduced":["2.11.0.0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","source":"GHSA-83x9-vc3c-hghc"}],"products":null,"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can bypass REST-layer authorization via malformed paths to access restricted endpoints in custom OpenSearch plugins.","url":"https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/"}