# GHSA-83x9-vc3c-hghc: OpenSearch has a bypass of REST Layer Authorization Using Malformed Paths

> Attackers can bypass REST-layer authorization via malformed paths to access restricted endpoints in custom OpenSearch plugins.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026

## What is GHSA-83x9-vc3c-hghc?

GHSA-83x9-vc3c-hghc is an authentication bypass vulnerability in org.opensearch.plugin:opensearch-security, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Description

A flaw was identified in the OpenSearch REST layer that could allow authorization checks to be bypassed when processing certain malformed HTTP requests. This could permit unauthorized access to restricted API endpoints in environments that rely on REST-layer authorization.

Transport-level authorization is not affected by this issue.

### Impact

The default OpenSearch distribution is not affected by this issue. REST actions in the default distribution have corresponding transport actions that independently enforce authorization. Custom plugins that register REST actions without a corresponding transport action may be affected, potentially allowing unauthorized read access to those endpoints.

### Patches

This issue is fixed in OpenSearch 2.19.0. Users should upgrade to 2.19.0 or later.

## Which versions are affected by GHSA-83x9-vc3c-hghc?

2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensearch.plugin:opensearch-security` | Maven | From 2.11.0.0 | 2.19.0.0 |
| `org.opensearch.plugin:opensearch-security` | Maven | From 2.11.0.0 | 2.19.0.0 |

## How do I fix GHSA-83x9-vc3c-hghc?

Upgrade org.opensearch.plugin:opensearch-security to 2.19.0.0 or later.

## Is GHSA-83x9-vc3c-hghc being exploited?

There is no known exploitation of GHSA-83x9-vc3c-hghc in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-83x9-vc3c-hghc and fix it if it is affected.

What it is: GHSA-83x9-vc3c-hghc is an authentication bypass vulnerability in org.opensearch.plugin:opensearch-security, published on 7 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-83x9-vc3c-hghc in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opensearch.plugin:opensearch-security (Maven): affected from 2.11.0.0; fixed in 2.19.0.0
- org.opensearch.plugin:opensearch-security (Maven): affected from 2.11.0.0; fixed in 2.19.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/ (Markdown: https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-83x9-vc3c-hghc

---
From sbomify Insights: https://insights.sbomify.com/GHSA-83x9-vc3c-hghc/
Summaries are generated and may contain mistakes; the official description above is the record.
