# GHSA-85q9-7467-r53q: XSS Vulnerability in Markdown Editor

> An attacker with low privileges can inject malicious scripts into markdown fields, leading to code execution in other users' browsers.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2022

## What is GHSA-85q9-7467-r53q?

GHSA-85q9-7467-r53q is a cross-site scripting vulnerability in inventree, published on 17 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

### Impact

InvenTree uses [EasyMDE](https://github.com/Ionaru/easy-markdown-editor) for displaying markdown text in various places (e.g. for the various "notes" fields associated with various models).

By default, EasyMDE does not sanitize input data, and it is possible for malicious code to be injected into the markdown editor, and executed in the users browser.

*Note: This malicious data must be first uploaded to the database by an authorized user, so the risk here is limited to trusted users*

### Solution

The solution here is two-fold:

- Enable data sanitization for the EasyMDE renderer - [#3205](https://github.com/inventree/InvenTree/pull/3205)
- Enforce cleaning of all data uploaded to the database via the API - [#3204](https://github.com/inventree/InvenTree/pull/3204) *(This will be ready for the 0.8.0 release)*

### Patches

- The issue is addressed in the 0.8.0 release
- This fix was back-ported to the 0.7.x branch, applied to the 0.7.3 release

### Workarounds

There is no workaround for this issue without upgrading InvenTree to the specified version.

### References

- https://huntr.dev/bounties/ab296cf5-7a3e-4f49-8f63-5b35fc707f03/

### For more information

If you have any questions or comments about this advisory:

* Open an issue in [github](http://github.com/inventree/inventree)
* Email us at [security@inventree.org](mailto:security@inventree.org)

## Which versions are affected by GHSA-85q9-7467-r53q?

2 open source packages ship an affected version, including inventree.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `inventree` | PyPI | All versions | 0.7.3 |
| `inventree` | PyPI | All versions | 0.7.3 |

## How do I fix GHSA-85q9-7467-r53q?

Upgrade inventree to 0.7.3 or later.

## Is GHSA-85q9-7467-r53q being exploited?

There is no known exploitation of GHSA-85q9-7467-r53q in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-85q9-7467-r53q and fix it if it is affected.

What it is: GHSA-85q9-7467-r53q is a cross-site scripting vulnerability in inventree, published on 17 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-85q9-7467-r53q in the wild and no public exploit code.

Affected packages and fixed versions:
- inventree (PyPI): affected all versions; fixed in 0.7.3
- inventree (PyPI): affected all versions; fixed in 0.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-85q9-7467-r53q/ (Markdown: https://insights.sbomify.com/GHSA-85q9-7467-r53q/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-85q9-7467-r53q

---
From sbomify Insights: https://insights.sbomify.com/GHSA-85q9-7467-r53q/
Summaries are generated and may contain mistakes; the official description above is the record.
