{"answers":{"affected":"3 open source packages ship an affected version, including github.com/k8sgpt-ai/k8sgpt.","exploited":"There is no known exploitation of GHSA-85rg-8m6h-825p in the wild and no public exploit code.","fix":"Upgrade github.com/k8sgpt-ai/k8sgpt to 0.3.33 or later.","what":"GHSA-85rg-8m6h-825p is a vulnerability in github.com/k8sgpt-ai/k8sgpt, published on 13 Jun 2024."},"fix_prompt":"Check this codebase for GHSA-85rg-8m6h-825p and fix it if it is affected.\n\nWhat it is: GHSA-85rg-8m6h-825p is a vulnerability in github.com/k8sgpt-ai/k8sgpt, published on 13 Jun 2024. \nExploitation: There is no known exploitation of GHSA-85rg-8m6h-825p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/k8sgpt-ai/k8sgpt (Go): affected all versions; fixed in 0.3.33\n- github.com/k8sgpt-ai/k8sgpt (Go): affected all versions; fixed in 0.3.33\n- github.com/k8sgpt-ai/k8sgpt (Go): affected all versions; fixed in 0.3.33\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-85rg-8m6h-825p/ (Markdown: https://insights.sbomify.com/GHSA-85rg-8m6h-825p/index.md)","id":"GHSA-85rg-8m6h-825p","markdown":"https://insights.sbomify.com/GHSA-85rg-8m6h-825p/index.md","name":"GHSA-85rg-8m6h-825p","record":{"aliases":["GO-2024-2923"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["other"],"network_reachable":"unknown","non_default_config":false,"product_category":"Kubernetes AI tool","requires_auth":"unknown","summary":"Multiple vulnerabilities were identified in the k8sGPT tool, requiring users to upgrade to the latest release to mitigate potential risks.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nBunch of vulnerabilities found in k8sGPT.  Fixed in release https://github.com/k8sgpt-ai/k8sgpt/releases/tag/v0.3.33","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Vulnerabilities with the k8sGPT","id":"GHSA-85rg-8m6h-825p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"other","year":"2024"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["0.3.33"],"introduced":["0"],"last_affected":[],"package":"github.com/k8sgpt-ai/k8sgpt","purl":null,"source":"GHSA-85rg-8m6h-825p"},{"ecosystem":"Go","fixed":["0.3.33"],"introduced":["0"],"last_affected":[],"package":"github.com/k8sgpt-ai/k8sgpt","purl":"pkg:golang/github.com/k8sgpt-ai/k8sgpt","source":"GHSA-85rg-8m6h-825p"},{"ecosystem":"Go","fixed":["0.3.33"],"introduced":["0"],"last_affected":[],"package":"github.com/k8sgpt-ai/k8sgpt","purl":"pkg:golang/github.com/k8sgpt-ai/k8sgpt","source":"GO-2024-2923"}],"products":null,"published":"2024-06-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Multiple vulnerabilities were identified in the k8sGPT tool, requiring users to upgrade to the latest release to mitigate potential risks.","url":"https://insights.sbomify.com/GHSA-85rg-8m6h-825p/"}