# GHSA-862m-5253-832r: Auth0 Wordpress Plugin vulnerable to Deserialization of Untrusted Data

> Attackers can execute arbitrary code by sending malicious serialized data in cookies to sites using the Auth0 WordPress plugin.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2025

## What is GHSA-862m-5253-832r?

GHSA-862m-5253-832r is an unsafe deserialization vulnerability in auth0/wordpress, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

**Overview**
The Auth0 Wordpress plugin contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.

**Am I Affected?**
You are affected by this vulnerability if you meet the following preconditions:

1. Applications using the Auth0 WordPress plugin, versions between 5.0.0 BETA-0 to 5.0.1. 
2. Auth0 WordPress plugin uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0.

**Fix**
Upgrade the Auth0 WordPress plugin to the latest version (v5.3.0).

## Which versions are affected by GHSA-862m-5253-832r?

2 open source packages ship an affected version, including auth0/wordpress.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/wordpress` | Packagist | From 5.0.0-BETA0 | 5.1.0 |
| `auth0/wordpress` | Packagist | From 5.0.0-BETA0 | 5.1.0 |

## How do I fix GHSA-862m-5253-832r?

Upgrade auth0/wordpress to 5.1.0 or later.

## Is GHSA-862m-5253-832r being exploited?

There is no known exploitation of GHSA-862m-5253-832r in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-862m-5253-832r and fix it if it is affected.

What it is: GHSA-862m-5253-832r is an unsafe deserialization vulnerability in auth0/wordpress, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-862m-5253-832r in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/wordpress (Packagist): affected from 5.0.0-BETA0; fixed in 5.1.0
- auth0/wordpress (Packagist): affected from 5.0.0-BETA0; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-862m-5253-832r/ (Markdown: https://insights.sbomify.com/GHSA-862m-5253-832r/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-862m-5253-832r

---
From sbomify Insights: https://insights.sbomify.com/GHSA-862m-5253-832r/
Summaries are generated and may contain mistakes; the official description above is the record.
