GHSA-86mr-6m89-vgj3 Buffer Overflow in node-weakauras-parser
A buffer overflow in node-weakauras-parser allows attackers to cause denial of service or execute arbitrary code via crafted input.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-86mr-6m89-vgj3?
GHSA-86mr-6m89-vgj3 is a memory corruption vulnerability in node-weakauras-parser, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Affected versions of node-weakauras-parser are vulnerable to a Buffer Overflow. The encode_weakaura function fails to properly validate the input size. A buffer of 13835058055282163711 bytes causes an overflow on 64-bit systems.
Recommendation
Upgrade to versions 1.0.5, 2.0.2, 3.0.1 or later.
Which versions are affected by GHSA-86mr-6m89-vgj3?
6 open source packages ship an affected version, including node-weakauras-parser.
| Package | Affected | Fixed in |
|---|---|---|
node-weakauras-parser npm | From 1.0.4 | 1.0.5 |
node-weakauras-parser npm | From 1.0.4 | 1.0.5 |
node-weakauras-parser npm | From 2.0.0 | 2.0.2 |
node-weakauras-parser npm | From 2.0.0 | 2.0.2 |
node-weakauras-parser npm | From 3.0.0 | 3.0.1 |
node-weakauras-parser npm | From 3.0.0 | 3.0.1 |
How do I fix GHSA-86mr-6m89-vgj3?
Upgrade node-weakauras-parser to a fixed version for your release line: 1.0.5, 2.0.2 or 3.0.1.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is GHSA-86mr-6m89-vgj3 being exploited?
There is no known exploitation of GHSA-86mr-6m89-vgj3 in the wild and no public exploit code.