{"answers":{"affected":"6 open source packages ship an affected version, including node-weakauras-parser.","exploited":"There is no known exploitation of GHSA-86mr-6m89-vgj3 in the wild and no public exploit code.","fix":"Upgrade node-weakauras-parser to a fixed version for your release line: 1.0.5, 2.0.2 or 3.0.1.","what":"GHSA-86mr-6m89-vgj3 is a memory corruption vulnerability in node-weakauras-parser, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-86mr-6m89-vgj3 and fix it if it is affected.\n\nWhat it is: GHSA-86mr-6m89-vgj3 is a memory corruption vulnerability in node-weakauras-parser, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-86mr-6m89-vgj3 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-weakauras-parser (npm): affected from 1.0.4; fixed in 1.0.5\n- node-weakauras-parser (npm): affected from 1.0.4; fixed in 1.0.5\n- node-weakauras-parser (npm): affected from 2.0.0; fixed in 2.0.2\n- node-weakauras-parser (npm): affected from 2.0.0; fixed in 2.0.2\n- node-weakauras-parser (npm): affected from 3.0.0; fixed in 3.0.1\n- node-weakauras-parser (npm): affected from 3.0.0; fixed in 3.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/ (Markdown: https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/index.md)","id":"GHSA-86mr-6m89-vgj3","markdown":"https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/index.md","name":"GHSA-86mr-6m89-vgj3","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js parsing library","requires_auth":"none","summary":"A buffer overflow in node-weakauras-parser allows attackers to cause denial of service or execute arbitrary code via crafted input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of `node-weakauras-parser` are vulnerable to a Buffer Overflow. The `encode_weakaura` function fails to properly validate the input size. A buffer of 13835058055282163711 bytes causes an overflow on 64-bit systems.\n\n## Recommendation\n\nUpgrade to versions 1.0.5, 2.0.2, 3.0.1 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Buffer Overflow in node-weakauras-parser","id":"GHSA-86mr-6m89-vgj3","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"memory_corruption","year":"2020"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["1.0.4"],"last_affected":[],"package":"node-weakauras-parser","purl":null,"source":"GHSA-86mr-6m89-vgj3"},{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["1.0.4"],"last_affected":[],"package":"node-weakauras-parser","purl":"pkg:npm/node-weakauras-parser","source":"GHSA-86mr-6m89-vgj3"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"node-weakauras-parser","purl":null,"source":"GHSA-86mr-6m89-vgj3"},{"ecosystem":"npm","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"node-weakauras-parser","purl":"pkg:npm/node-weakauras-parser","source":"GHSA-86mr-6m89-vgj3"},{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"node-weakauras-parser","purl":null,"source":"GHSA-86mr-6m89-vgj3"},{"ecosystem":"npm","fixed":["3.0.1"],"introduced":["3.0.0"],"last_affected":[],"package":"node-weakauras-parser","purl":"pkg:npm/node-weakauras-parser","source":"GHSA-86mr-6m89-vgj3"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A buffer overflow in node-weakauras-parser allows attackers to cause denial of service or execute arbitrary code via crafted input.","url":"https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/"}