# GHSA-86mr-6m89-vgj3: Buffer Overflow in node-weakauras-parser

> A buffer overflow in node-weakauras-parser allows attackers to cause denial of service or execute arbitrary code via crafted input.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Sep 2020

## What is GHSA-86mr-6m89-vgj3?

GHSA-86mr-6m89-vgj3 is a memory corruption vulnerability in node-weakauras-parser, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Affected versions of `node-weakauras-parser` are vulnerable to a Buffer Overflow. The `encode_weakaura` function fails to properly validate the input size. A buffer of 13835058055282163711 bytes causes an overflow on 64-bit systems.

## Recommendation

Upgrade to versions 1.0.5, 2.0.2, 3.0.1 or later.

## Which versions are affected by GHSA-86mr-6m89-vgj3?

6 open source packages ship an affected version, including node-weakauras-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-weakauras-parser` | npm | From 1.0.4 | 1.0.5 |
| `node-weakauras-parser` | npm | From 1.0.4 | 1.0.5 |
| `node-weakauras-parser` | npm | From 2.0.0 | 2.0.2 |
| `node-weakauras-parser` | npm | From 2.0.0 | 2.0.2 |
| `node-weakauras-parser` | npm | From 3.0.0 | 3.0.1 |
| `node-weakauras-parser` | npm | From 3.0.0 | 3.0.1 |

## How do I fix GHSA-86mr-6m89-vgj3?

Upgrade node-weakauras-parser to a fixed version for your release line: 1.0.5, 2.0.2 or 3.0.1.

## Is GHSA-86mr-6m89-vgj3 being exploited?

There is no known exploitation of GHSA-86mr-6m89-vgj3 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-86mr-6m89-vgj3 and fix it if it is affected.

What it is: GHSA-86mr-6m89-vgj3 is a memory corruption vulnerability in node-weakauras-parser, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-86mr-6m89-vgj3 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-weakauras-parser (npm): affected from 1.0.4; fixed in 1.0.5
- node-weakauras-parser (npm): affected from 1.0.4; fixed in 1.0.5
- node-weakauras-parser (npm): affected from 2.0.0; fixed in 2.0.2
- node-weakauras-parser (npm): affected from 2.0.0; fixed in 2.0.2
- node-weakauras-parser (npm): affected from 3.0.0; fixed in 3.0.1
- node-weakauras-parser (npm): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/ (Markdown: https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-86mr-6m89-vgj3

---
From sbomify Insights: https://insights.sbomify.com/GHSA-86mr-6m89-vgj3/
Summaries are generated and may contain mistakes; the official description above is the record.
