{"answers":{"affected":"2 open source packages ship an affected version, including fgr.","exploited":"There is no known exploitation of GHSA-879p-8gw4-mcpw in the wild and no public exploit code.","fix":"No fix has been published for GHSA-879p-8gw4-mcpw yet. Limit exposure of the affected software until one is available.","what":"GHSA-879p-8gw4-mcpw is a vulnerability in fgr, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-879p-8gw4-mcpw and fix it if it is affected.\n\nWhat it is: GHSA-879p-8gw4-mcpw is a vulnerability in fgr, published on 15 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-879p-8gw4-mcpw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fgr (PyPI): affected all versions up to 0.3.2; no fix listed\n- fgr (PyPI): affected all versions up to 0.3.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-879p-8gw4-mcpw/ (Markdown: https://insights.sbomify.com/GHSA-879p-8gw4-mcpw/index.md)","id":"GHSA-879p-8gw4-mcpw","markdown":"https://insights.sbomify.com/GHSA-879p-8gw4-mcpw/index.md","name":"GHSA-879p-8gw4-mcpw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python logging library","requires_auth":"none","summary":"Attackers with log access can view sensitive data in tracebacks due to insecure default variable initialization in the fgr library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAny users whom would not desire a traceback to be included in their logs whenever an error is raised in their code will be affected.\n\nIf users have inadvertently created a scenario in their code that could cause a traceback to include sensitive information _and_ a malicious entity gained access to their log stream, this could create an issue.\n\n### Patches\nNone yet... users will need to upgrade to `0.4.*`\n\n### Workarounds\nNo particularly reasonable ones at present.\n\n### References\n* https://cwe.mitre.org/data/definitions/453.html\n* https://www.invicti.com/web-vulnerability-scanner/vulnerabilities/stack-trace-disclosure-python/","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"fgr Vulnerable to Insecure Default Variable Initialization","id":"GHSA-879p-8gw4-mcpw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.3.2"],"package":"fgr","purl":null,"source":"GHSA-879p-8gw4-mcpw"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.3.2"],"package":"fgr","purl":"pkg:pypi/fgr","source":"GHSA-879p-8gw4-mcpw"}],"products":null,"published":"2024-03-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers with log access can view sensitive data in tracebacks due to insecure default variable initialization in the fgr library.","url":"https://insights.sbomify.com/GHSA-879p-8gw4-mcpw/"}