{"answers":{"affected":"2 open source packages ship an affected version, including gun.","exploited":"There is no known exploitation of GHSA-886v-mm6p-4m66 in the wild and no public exploit code.","fix":"Upgrade gun to 0.2019.416 or later.","what":"GHSA-886v-mm6p-4m66 is a path traversal vulnerability in gun, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-886v-mm6p-4m66 and fix it if it is affected.\n\nWhat it is: GHSA-886v-mm6p-4m66 is a path traversal vulnerability in gun, published on 5 Jun 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-886v-mm6p-4m66 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gun (npm): affected all versions; fixed in 0.2019.416\n- gun (npm): affected all versions; fixed in 0.2019.416\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-886v-mm6p-4m66/ (Markdown: https://insights.sbomify.com/GHSA-886v-mm6p-4m66/index.md)","id":"GHSA-886v-mm6p-4m66","markdown":"https://insights.sbomify.com/GHSA-886v-mm6p-4m66/index.md","name":"GHSA-886v-mm6p-4m66","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js database library","requires_auth":"none","summary":"An attacker can read arbitrary files from the server via path traversal in the static file server, potentially leaking sensitive environment variables and keys.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Urgent Upgrade\n\nThe static file server module included with GUN had a **serious vulnerability**:\n\n - Using `curl --path-as-is` allowed reads on any parent directory or files.\n\nThis did not work via the browser or via curl without as-is option.\n\n ### Fixed\n\nThis has been fixed since version `0.2019.416` and higher.\n\n ### Who Was Effected?\n\nMost NodeJS users who use the default setup, such as:\n\n - `npm start`\n - `node examples/http.js`\n - `Heroku` 1-click-deploy\n - `Docker`\n - `Now`\n\nIf you have a custom NodeJS code then you are probably safe *unless* you have something like `require('http').createServer(Gun.serve(__dirname))` in it.\n\nIf you have not upgraded, it is **mandatory** or else it is highly likely your environment variables and AWS (or other) keys could be leaked.\n\n ### Credit\n\nIt was reported and fixed by [JK0N](https://github.com/amark/gun/pull/527), but I did not understand the `--path-as-is` condition.\n\nJoonas Loppi from [function61](http://function61.com) rediscovered it and explained the urgency to me to fix it.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"High severity vulnerability that affects gun","id":"GHSA-886v-mm6p-4m66","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2019"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.2019.416"],"introduced":["0"],"last_affected":[],"package":"gun","purl":null,"source":"GHSA-886v-mm6p-4m66"},{"ecosystem":"npm","fixed":["0.2019.416"],"introduced":["0"],"last_affected":[],"package":"gun","purl":"pkg:npm/gun","source":"GHSA-886v-mm6p-4m66"}],"products":null,"published":"2019-06-05","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can read arbitrary files from the server via path traversal in the static file server, potentially leaking sensitive environment variables and keys.","url":"https://insights.sbomify.com/GHSA-886v-mm6p-4m66/"}