GHSA-8948-ffc6-jg52 Insecure Default Configuration in redbird

Not scored Published
Exploited in the wild
Not known
Fix
None listed

What is GHSA-8948-ffc6-jg52?

GHSA-8948-ffc6-jg52 is a vulnerability in redbird, published on 6 Jun 2019.

Official description

Versions of redbird prior to 0.9.1 have a vulnerable default configuration of allowing TLS 1.0 connections on lib/proxy.js. The package does not provide an option to disable TLS 1.0 which is deprecated and vulnerable.

Recommendation

Upgrade to version 0.9.1 or later.

Which versions are affected by GHSA-8948-ffc6-jg52?

2 open source packages ship an affected version, including redbird.

PackageAffectedFixed in
redbird npmAll versions to 0.9.0None
redbird npmAll versions to 0.9.0None

How do I fix GHSA-8948-ffc6-jg52?

No fix has been published for GHSA-8948-ffc6-jg52 yet. Limit exposure of the affected software until one is available.

Is GHSA-8948-ffc6-jg52 being exploited?

There is no known exploitation of GHSA-8948-ffc6-jg52 in the wild and no public exploit code.

Sources

Is GHSA-8948-ffc6-jg52 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free