# GHSA-8948-ffc6-jg52: Insecure Default Configuration in redbird


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 6 Jun 2019

## What is GHSA-8948-ffc6-jg52?

GHSA-8948-ffc6-jg52 is a vulnerability in redbird, published on 6 Jun 2019. 

### Official description

Versions of `redbird` prior to 0.9.1 have a vulnerable default configuration of allowing TLS 1.0 connections on `lib/proxy.js`. The package does not provide an option to disable TLS 1.0 which is deprecated and vulnerable.

## Recommendation

Upgrade to version 0.9.1 or later.

## Which versions are affected by GHSA-8948-ffc6-jg52?

2 open source packages ship an affected version, including redbird.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redbird` | npm | All versions to 0.9.0 | None |
| `redbird` | npm | All versions to 0.9.0 | None |

## How do I fix GHSA-8948-ffc6-jg52?

No fix has been published for GHSA-8948-ffc6-jg52 yet. Limit exposure of the affected software until one is available.

## Is GHSA-8948-ffc6-jg52 being exploited?

There is no known exploitation of GHSA-8948-ffc6-jg52 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8948-ffc6-jg52 and fix it if it is affected.

What it is: GHSA-8948-ffc6-jg52 is a vulnerability in redbird, published on 6 Jun 2019. 
Exploitation: There is no known exploitation of GHSA-8948-ffc6-jg52 in the wild and no public exploit code.

Affected packages and fixed versions:
- redbird (npm): affected all versions up to 0.9.0; no fix listed
- redbird (npm): affected all versions up to 0.9.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8948-ffc6-jg52/ (Markdown: https://insights.sbomify.com/GHSA-8948-ffc6-jg52/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8948-ffc6-jg52

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8948-ffc6-jg52/
Summaries are generated and may contain mistakes; the official description above is the record.
