{"answers":{"affected":"2 open source packages ship an affected version, including Whatsapp-Chat-Exporter and whatsapp-chat-exporter.","exploited":"There is no known exploitation of GHSA-8c6x-g4fw-8rf4 in the wild and no public exploit code.","fix":"Upgrade Whatsapp-Chat-Exporter to 0.9.5 or later.","what":"GHSA-8c6x-g4fw-8rf4 is a cross-site scripting vulnerability in Whatsapp-Chat-Exporter, published on 10 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-8c6x-g4fw-8rf4 and fix it if it is affected.\n\nWhat it is: GHSA-8c6x-g4fw-8rf4 is a cross-site scripting vulnerability in Whatsapp-Chat-Exporter, published on 10 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-8c6x-g4fw-8rf4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- Whatsapp-Chat-Exporter (PyPI): affected all versions; fixed in 0.9.5\n- whatsapp-chat-exporter (PyPI): affected all versions; fixed in 0.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8c6x-g4fw-8rf4/ (Markdown: https://insights.sbomify.com/GHSA-8c6x-g4fw-8rf4/index.md)","id":"GHSA-8c6x-g4fw-8rf4","markdown":"https://insights.sbomify.com/GHSA-8c6x-g4fw-8rf4/index.md","name":"GHSA-8c6x-g4fw-8rf4","record":{"aliases":[],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"WhatsApp chat exporter","requires_auth":"none","summary":"An XSS vulnerability in WhatsApp-Chat-Exporter allows attackers to inject malicious scripts into exported HTML chat files, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nA Cross-Site Scripting (XSS) vulnerability was found in the HTML output of chats. XSS is intended to be mitigated by Jinja's escape function. However, `autoescape=True` was missing when setting the environment. Although the actual impact is low, considering the HTML file is being viewed offline, an adversary may still be able to inject malicious payloads into the chat through WhatsApp. All users are affected.\n\n### Patches\nThe vulnerability is patched in 0.9.5. All users are strongly advised to update the exporter to the latest version.\n\n### Workarounds\nNo workaround is available. Please update the exporter to the latest version.\n\n### References\nhttps://github.com/KnugiHK/WhatsApp-Chat-Exporter/commit/bfdc68cd6ad53ceecf132773f9aaba50dd80fe79\nhttps://owasp.org/www-community/attacks/xss/","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Whatsapp-Chat-Exporter has Cross-Site Scripting vulnerability in HTML output of chats.","id":"GHSA-8c6x-g4fw-8rf4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["0.9.5"],"introduced":["0"],"last_affected":[],"package":"Whatsapp-Chat-Exporter","purl":null,"source":"GHSA-8c6x-g4fw-8rf4"},{"ecosystem":"PyPI","fixed":["0.9.5"],"introduced":["0"],"last_affected":[],"package":"whatsapp-chat-exporter","purl":"pkg:pypi/whatsapp-chat-exporter","source":"GHSA-8c6x-g4fw-8rf4"}],"products":null,"published":"2023-07-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in WhatsApp-Chat-Exporter allows attackers to inject malicious scripts into exported HTML chat files, requiring user interaction to execute.","url":"https://insights.sbomify.com/GHSA-8c6x-g4fw-8rf4/"}