GHSA-8c85-4rr5-chr4 Cross-site Scripting (XSS) in DemoBundle/ezdemo bundled VideoJS

Not scored Published

An XSS vulnerability in the bundled VideoJS Flash player allows attackers to execute scripts in the context of users viewing videos in the eZ Publish DemoBundle.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is GHSA-8c85-4rr5-chr4?

GHSA-8c85-4rr5-chr4 is a cross-site scripting vulnerability in ezsystems/demobundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

This Security Advisory is about a vulnerability in VideoJS, which is bundled in DemoBundle and the ezdemo legacy extension. Older releases of VideoJS contain an XSS vulnerability in the Flash-based video player. This is bundled in DemoBundle, and in the Legacy "ezdemo" and "ezdemo-ls-extension" extensions. Among the branches still receiving security advisories, only eZ Publish Platform 5.4 and eZ Publish Legacy 5.4 are affected. However, it may be possible to make this software work in newer branches, so please check whether you have it installed even if you're using eZ Platform 1.x or 2.x.

Because DemoBundle / ezdemo are only intended for demo purposes, they are not supported software. For that reason, and given the old age of the software, and manpower issues during the Coronavirus crisis, we are taking the unusual step of simply removing the affected file. This resolves the vulnerability, but also breaks the video playback feature. It may be possible to make it work again by upgrading to a current version of VideoJS, but it is unlikely that we will do this, given the reasons already mentioned.

Which versions are affected by GHSA-8c85-4rr5-chr4?

2 open source packages ship an affected version, including ezsystems/demobundle.

PackageAffectedFixed in
ezsystems/demobundle PackagistFrom 5.4.05.4.6.1
ezsystems/demobundle PackagistFrom 5.4.05.4.6.1

How do I fix GHSA-8c85-4rr5-chr4?

Upgrade ezsystems/demobundle to 5.4.6.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is GHSA-8c85-4rr5-chr4 being exploited?

There is no known exploitation of GHSA-8c85-4rr5-chr4 in the wild and no public exploit code.

Sources

Is GHSA-8c85-4rr5-chr4 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free