{"answers":{"affected":"2 open source packages ship an affected version, including ezsystems/demobundle.","exploited":"There is no known exploitation of GHSA-8c85-4rr5-chr4 in the wild and no public exploit code.","fix":"Upgrade ezsystems/demobundle to 5.4.6.1 or later.","what":"GHSA-8c85-4rr5-chr4 is a cross-site scripting vulnerability in ezsystems/demobundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-8c85-4rr5-chr4 and fix it if it is affected.\n\nWhat it is: GHSA-8c85-4rr5-chr4 is a cross-site scripting vulnerability in ezsystems/demobundle, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-8c85-4rr5-chr4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/demobundle (Packagist): affected from 5.4.0; fixed in 5.4.6.1\n- ezsystems/demobundle (Packagist): affected from 5.4.0; fixed in 5.4.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8c85-4rr5-chr4/ (Markdown: https://insights.sbomify.com/GHSA-8c85-4rr5-chr4/index.md)","id":"GHSA-8c85-4rr5-chr4","markdown":"https://insights.sbomify.com/GHSA-8c85-4rr5-chr4/index.md","name":"GHSA-8c85-4rr5-chr4","record":{"aliases":[],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"eZ Publish DemoBundle","requires_auth":"none","summary":"An XSS vulnerability in the bundled VideoJS Flash player allows attackers to execute scripts in the context of users viewing videos in the eZ Publish DemoBundle.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This Security Advisory is about a vulnerability in VideoJS, which is bundled in DemoBundle and the ezdemo legacy extension. Older releases of VideoJS contain an XSS vulnerability in the Flash-based video player. This is bundled in DemoBundle, and in the Legacy \"ezdemo\" and \"ezdemo-ls-extension\" extensions. Among the branches still receiving security advisories, only eZ Publish Platform 5.4 and eZ Publish Legacy 5.4 are affected. However, it may be possible to make this software work in newer branches, so please check whether you have it installed even if you're using eZ Platform 1.x or 2.x.\n\nBecause DemoBundle / ezdemo are only intended for demo purposes, they are not supported software. For that reason, and given the old age of the software, and manpower issues during the Coronavirus crisis, we are taking the unusual step of simply removing the affected file. This resolves the vulnerability, but also breaks the video playback feature. It may be possible to make it work again by upgrading to a current version of VideoJS, but it is unlikely that we will do this, given the reasons already mentioned.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-site Scripting (XSS) in DemoBundle/ezdemo bundled VideoJS","id":"GHSA-8c85-4rr5-chr4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["5.4.6.1"],"introduced":["5.4.0"],"last_affected":[],"package":"ezsystems/demobundle","purl":null,"source":"GHSA-8c85-4rr5-chr4"},{"ecosystem":"Packagist","fixed":["5.4.6.1"],"introduced":["5.4.0"],"last_affected":[],"package":"ezsystems/demobundle","purl":"pkg:composer/ezsystems/demobundle","source":"GHSA-8c85-4rr5-chr4"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An XSS vulnerability in the bundled VideoJS Flash player allows attackers to execute scripts in the context of users viewing videos in the eZ Publish DemoBundle.","url":"https://insights.sbomify.com/GHSA-8c85-4rr5-chr4/"}