{"answers":{"affected":"2 open source packages ship an affected version, including redis-commander.","exploited":"There is no known exploitation of GHSA-8c8c-4vfj-rrpc in the wild and no public exploit code.","fix":"Upgrade redis-commander to 0.5.0 or later.","what":"GHSA-8c8c-4vfj-rrpc is a cross-site scripting vulnerability in redis-commander, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-8c8c-4vfj-rrpc and fix it if it is affected.\n\nWhat it is: GHSA-8c8c-4vfj-rrpc is a cross-site scripting vulnerability in redis-commander, published on 1 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-8c8c-4vfj-rrpc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- redis-commander (npm): affected from 0.0.0; fixed in 0.5.0\n- redis-commander (npm): affected from 0.0.0; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8c8c-4vfj-rrpc/ (Markdown: https://insights.sbomify.com/GHSA-8c8c-4vfj-rrpc/index.md)","id":"GHSA-8c8c-4vfj-rrpc","markdown":"https://insights.sbomify.com/GHSA-8c8c-4vfj-rrpc/index.md","name":"GHSA-8c8c-4vfj-rrpc","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Redis management tool","requires_auth":"none","summary":"Reflected XSS in redis-commander allows attackers to execute scripts if Flash is enabled, requiring user interaction via a crafted link.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Affected versions of `redis-commander` contain a cross-site scripting vulnerability in the `highlighterId` paramter of the clipboard.swf component on hosts serving Redis Commander.\n\nMitigating factors:\nFlash must be installed / enabled for this to work. The below proof of concept was verified to work using Firefox 57.0 on Windows 10 by manually installing the [Flash NPAPI Windows plugin](https://get.adobe.com/flashplayer/otherversions/)\n\n## Proof of concept\n\n```\nhttp://instance/jstree/_docs/syntax/clipboard.swf?highlighterId=\\%22))}%20catch(e)%20{alert(document.domain);}//\n```\n\n## Recommendation\n\nNo direct patch for this vulnerability is currently available.\n\nAt this time, the best mitigation is to use an alternative, functionally equivalent package, or to use extreme caution when using redis-commander, ensuring that redis-commmander is the only web page you have open, and avoiding clicking on any links.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Reflected Cross-Site Scripting in redis-commander","id":"GHSA-8c8c-4vfj-rrpc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0.0.0"],"last_affected":[],"package":"redis-commander","purl":null,"source":"GHSA-8c8c-4vfj-rrpc"},{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0.0.0"],"last_affected":[],"package":"redis-commander","purl":"pkg:npm/redis-commander","source":"GHSA-8c8c-4vfj-rrpc"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Reflected XSS in redis-commander allows attackers to execute scripts if Flash is enabled, requiring user interaction via a crafted link.","url":"https://insights.sbomify.com/GHSA-8c8c-4vfj-rrpc/"}