# GHSA-8c8m-p3m8-cjg8: Nodemailer: A nested comment ends early in addressparser, releasing the rest of the comment as a recipient


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026

## What is GHSA-8c8m-p3m8-cjg8?

GHSA-8c8m-p3m8-cjg8 is a vulnerability in nodemailer, published on 23 Oct 2026. 

### Official description

### Vulnerability summary

RFC 5322 comments nest. addressparser ended a comment at the first `)`, including the one that closes a nested comment, and parsed the rest of the outer comment as header text. `Victim (x(y) <evil@evil.com>) <v@victim.com>` names `v@victim.com` with `x(y) <evil@evil.com>` as a comment, and Nodemailer read it as the address `evil@evil.com`. This is the same shape as the escaped parenthesis fixed in 10.1.2, reached through nesting instead of a quoted-pair. Affected: 3.0.0 through 10.1.3.

### Attacker capabilities

The attacker controls the text of an address that an application passes to Nodemailer, or the From or To header of an inbound message parsed with mailparser. No access to the application, its configuration or its credentials is needed. The value is a syntactically valid RFC 5322 address that conformant parsers accept without defects.

### Realistic exploitation scenario

An application validates a submitted address with a conformant parser and allows only its own domain. The attacker submits `Victim (x(y) <evil@evil.com>) <v@victim.com>`, which validates as `v@victim.com`. Nodemailer delivers to `evil@evil.com`. In the inbound direction, a DMARC or display layer built on a conformant parser and a mail client built on mailparser disagree on the author of the same message, which is the setting for sender spoofing. The boundary crossed is the application's recipient allow list, or the author check of the receiving side.

### Proof of concept

```js
const addressparser = require('nodemailer/lib/addressparser');
console.log(addressparser("Victim (x(y) <evil@evil.com>) <v@victim.com>"));
// [ { address: 'evil@evil.com', name: 'Victim) v@victim.com' } ]
```

Python's `email._header_value_parser.get_address_list` reads the same value as `v@victim.com` with the display name `Victim`, with no defects reported.

The envelope a message gets is built from the same parse, so `sendMail({ to: "Victim (x(y) <evil@evil.com>) <v@victim.com>" })` issues the RCPT TO shown above.

### Security impact

Mail intended for an approved recipient is delivered to an attacker chosen domain, disclosing its content, and parsers built on this module report a different author than conformant ones. The misreading only occurs on values a conformant validator approves, so correct validation is bypassed. Affected are applications that pass user influenced addresses to Nodemailer and consumers of the standalone parser such as mailparser.

The fix counts comment depth and ends a comment only at the `)` that closes the outermost one.

Found in an internal review of addressparser on 2026-10-18. Verified on 3.0.0, 6.9.16 and 10.1.3.

## Which versions are affected by GHSA-8c8m-p3m8-cjg8?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | From 3.0.0 | 10.1.4 |
| `nodemailer` | npm | From 3.0.0 | 10.1.4 |

## How do I fix GHSA-8c8m-p3m8-cjg8?

Upgrade nodemailer to 10.1.4 or later.

## Is GHSA-8c8m-p3m8-cjg8 being exploited?

There is no known exploitation of GHSA-8c8m-p3m8-cjg8 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8c8m-p3m8-cjg8 and fix it if it is affected.

What it is: GHSA-8c8m-p3m8-cjg8 is a vulnerability in nodemailer, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of GHSA-8c8m-p3m8-cjg8 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodemailer (npm): affected from 3.0.0; fixed in 10.1.4
- nodemailer (npm): affected from 3.0.0; fixed in 10.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8c8m-p3m8-cjg8/ (Markdown: https://insights.sbomify.com/GHSA-8c8m-p3m8-cjg8/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8c8m-p3m8-cjg8

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8c8m-p3m8-cjg8/
Summaries are generated and may contain mistakes; the official description above is the record.
