{"answers":{"affected":"6 open source packages ship an affected version, including idunno.AtProto, idunno.AtProto.OAuthCallback and idunno.Bluesky.","exploited":"There is no known exploitation of GHSA-8fh9-c4jq-94h4 in the wild and no public exploit code.","fix":"Upgrade idunno.AtProto to 1.7.0 or later.","what":"GHSA-8fh9-c4jq-94h4 is a denial of service vulnerability in idunno.AtProto, published on 13 Mar 2026. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-8fh9-c4jq-94h4 and fix it if it is affected.\n\nWhat it is: GHSA-8fh9-c4jq-94h4 is a denial of service vulnerability in idunno.AtProto, published on 13 Mar 2026. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-8fh9-c4jq-94h4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- idunno.AtProto (NuGet): affected all versions; fixed in 1.7.0\n- idunno.AtProto (NuGet): affected all versions; fixed in 1.7.0\n- idunno.AtProto.OAuthCallback (NuGet): affected all versions; fixed in 1.7.0\n- idunno.AtProto.OAuthCallback (NuGet): affected all versions; fixed in 1.7.0\n- idunno.Bluesky (NuGet): affected all versions; fixed in 1.7.0\n- idunno.Bluesky (NuGet): affected all versions; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8fh9-c4jq-94h4/ (Markdown: https://insights.sbomify.com/GHSA-8fh9-c4jq-94h4/index.md)","id":"GHSA-8fh9-c4jq-94h4","markdown":"https://insights.sbomify.com/GHSA-8fh9-c4jq-94h4/index.md","name":"GHSA-8fh9-c4jq-94h4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Bluesky AtProto library","requires_auth":"unknown","summary":"A denial of service vulnerability in a transitive dependency affects Bluesky and AtProto libraries, requiring an upgrade to resolve.","user_interaction":"unknown","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"# idunno.Bluesky, idunno.AtProto and idunno.AtProto.OAuthCallback Denial of Service Vulnerability\n\n## Impact\n\nThe `Microsoft.Bcl.Memory` package, a transitive dependency of `idunno.AtProto` and `idunno.AtProto.OAuthCallback` had a Denial of Service security vulnerability, [CVE-2026-26127](https://github.com/dotnet/announcements/issues/384)\n\n## Patches\n\nv1.7.0 updates the dependencies on `Duende.IdentityModel.OidcClient` and `Duende.IdentityModel.OidcClient.Extensions` which, in turn, updates their dependency on `Microsoft.Bcl.Memory` to 10.0.4, resolving the vulnerability.\n\n## Workarounds\n\nNo workarounds exist for this vulnerability.\n\n## How to fix the issue\n\nTo update your dependencies on `idunno.Bluesky`, `idunno.AtProto` and `idunno.AtProto.OAuthCallback`, \n\n### Using the .NET CLI (Command Line Interface):\n\n* Open a terminal or command prompt in your project's directory.\n* To update a specific package to its latest version, use the following add package command:\n   \n  * If you are using `idunno.Bluesky`\n    `dotnet package update idunno.Bluesky`\n\n  * If you are using `idunno.AtProto` as a direct dependency\n    `dotnet package update idunno.AtProto`\n\n  * If you are using `idunno.AtProto.OAuthCallback` as a direct dependency\n    `dotnet package update idunno.AtProto.OAuthCallback`\n\n### Using the NuGet Package Manager Console in Visual Studio:\n\n* Open your project in Visual Studio.\n* Navigate to \"Tools \u003e NuGet Package Manager \u003e Package Manager Console\".\n* To update a specific package to its latest version, use the following Update-Package command:\n\n  * If you are using `idunno.Bluesky`\n    `Update-Package -Id idunno.Bluesky`\n\n  * If you are using `idunno.AtProto` as a direct dependency\n    `Update-Package -Id idunno.AtProto`\n\n  * If you are using `idunno.AtProto.OAuthCallback` as a direct dependency\n    `Update-Package -Id idunno.AtProto.OAuthCallback`\n\n### NuGet Package Manager UI in Visual Studio:\n\n* Open your project in Visual Studio.\n* Right-click on your project in Solution Explorer and select \"Manage NuGet Packages...\" or navigate to \"Project \u003e Manage NuGet Packages\".\n* In the NuGet Package Manager window, select the \"Updates\" tab. This tab lists packages with available updates from your configured package sources.\n* Select the package(s) you wish to update. You can choose a specific version from the dropdown or update to the latest available version.\n* Click the \"Update\" button.\n\n## References\n\n*  [Microsoft Security Advisory CVE-2026-26127 – .NET Denial of Service Vulnerability](https://github.com/dotnet/announcements/issues/384)\n*  [CVE-2026-26127](https://www.cve.org/CVERecord?id=CVE-2026-26127)","ecosystems":["NuGet"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"idunno.Bluesky, idunno.AtProto and idunno.AtProto.OAuthCallback Denial of Service Vulnerability","id":"GHSA-8fh9-c4jq-94h4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":6,"n_references":null,"packages":[{"ecosystem":"NuGet","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"idunno.AtProto","purl":null,"source":"GHSA-8fh9-c4jq-94h4"},{"ecosystem":"NuGet","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"idunno.AtProto","purl":"pkg:nuget/idunno.AtProto","source":"GHSA-8fh9-c4jq-94h4"},{"ecosystem":"NuGet","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"idunno.AtProto.OAuthCallback","purl":null,"source":"GHSA-8fh9-c4jq-94h4"},{"ecosystem":"NuGet","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"idunno.AtProto.OAuthCallback","purl":"pkg:nuget/idunno.AtProto.OAuthCallback","source":"GHSA-8fh9-c4jq-94h4"},{"ecosystem":"NuGet","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"idunno.Bluesky","purl":null,"source":"GHSA-8fh9-c4jq-94h4"},{"ecosystem":"NuGet","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"idunno.Bluesky","purl":"pkg:nuget/idunno.Bluesky","source":"GHSA-8fh9-c4jq-94h4"}],"products":null,"published":"2026-03-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A denial of service vulnerability in a transitive dependency affects Bluesky and AtProto libraries, requiring an upgrade to resolve.","url":"https://insights.sbomify.com/GHSA-8fh9-c4jq-94h4/"}