{"answers":{"affected":"4 open source packages ship an affected version, including diagram-js.","exploited":"There is no known exploitation of GHSA-8fw4-xh83-3j6q in the wild and no public exploit code.","fix":"Upgrade diagram-js to a fixed version for your release line: 2.6.2 or 3.3.1.","what":"GHSA-8fw4-xh83-3j6q is a cross-site scripting vulnerability in diagram-js, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-8fw4-xh83-3j6q and fix it if it is affected.\n\nWhat it is: GHSA-8fw4-xh83-3j6q is a cross-site scripting vulnerability in diagram-js, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-8fw4-xh83-3j6q in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- diagram-js (npm): affected all versions; fixed in 2.6.2\n- diagram-js (npm): affected all versions; fixed in 2.6.2\n- diagram-js (npm): affected from 3.0.0; fixed in 3.3.1\n- diagram-js (npm): affected from 3.0.0; fixed in 3.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8fw4-xh83-3j6q/ (Markdown: https://insights.sbomify.com/GHSA-8fw4-xh83-3j6q/index.md)","id":"GHSA-8fw4-xh83-3j6q","markdown":"https://insights.sbomify.com/GHSA-8fw4-xh83-3j6q/index.md","name":"GHSA-8fw4-xh83-3j6q","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript diagram library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via unescaped input in search-pad, affecting users of the diagram-js library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `diagram-js` prior to 3.3.1 (for 3.x) and 2.6.2 (for 2.x) are vulnerable to Cross-Site Scripting. The package fails to escape output of user-controlled input in `search-pad`, allowing attackers to execute arbitrary JavaScript.\n\n## Recommendation\n\nIf you are using diagram-js 3.x, upgrade to version 3.3.1.\nIf you are using diagram-js 2.x, upgrade to version 2.6.2.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Cross-Site Scripting in diagram-js","id":"GHSA-8fw4-xh83-3j6q","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"diagram-js","purl":null,"source":"GHSA-8fw4-xh83-3j6q"},{"ecosystem":"npm","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"diagram-js","purl":"pkg:npm/diagram-js","source":"GHSA-8fw4-xh83-3j6q"},{"ecosystem":"npm","fixed":["3.3.1"],"introduced":["3.0.0"],"last_affected":[],"package":"diagram-js","purl":null,"source":"GHSA-8fw4-xh83-3j6q"},{"ecosystem":"npm","fixed":["3.3.1"],"introduced":["3.0.0"],"last_affected":[],"package":"diagram-js","purl":"pkg:npm/diagram-js","source":"GHSA-8fw4-xh83-3j6q"}],"products":null,"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript via unescaped input in search-pad, affecting users of the diagram-js library.","url":"https://insights.sbomify.com/GHSA-8fw4-xh83-3j6q/"}