# GHSA-8g98-m4j9-qww5: Taylored webhook validation vulnerabilities

> Attackers can read arbitrary server files via path traversal and bypass payment validation to access paid patches in the Taylored npm package.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2025

## What is GHSA-8g98-m4j9-qww5?

GHSA-8g98-m4j9-qww5 is a path traversal vulnerability in taylored, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

### Critical Security Advisory for Taylored npm package v7.0.7 - tag 7.0.5

#### Summary

A series of moderate to high-severity security vulnerabilities have been identified specifically in version **7.0.7 of \`taylored\`**. These vulnerabilities reside in the "Backend-in-a-Box" template distributed with this version. They could allow a malicious actor to read arbitrary files from the server, download paid patches without completing a valid purchase, and weaken the protection of encrypted patches.

**All users who have installed or generated a \`taysell-server\` using version 7.0.7 of \`taylored\` are strongly advised to immediately upgrade to version 7.0.8 (or later) and follow the required mitigation steps outlined below.** Versions prior to 7.0.7 did not include the Taysell functionality and are therefore not affected by these specific issues.

#### Vulnerabilities Patched in v7.0.8

Version 7.0.8 addresses the following issues found in the v7.0.7 template:

1.  **Path Traversal in Patch Download:** The patch download endpoint did not properly sanitize the user-provided \`patchId\`. An attacker could have crafted a request with path traversal sequences (e.g., \`../../etc/passwd\`) to read arbitrary files from the server's filesystem. The \`patchId\` is now sanitized to ensure only files within the intended patches directory can be accessed.
2.  **Missing PayPal Webhook Validation:** The server endpoint did not cryptographically verify incoming payment notifications, allowing an attacker to spoof a purchase and gain unauthorized access to patches.
3.  **Purchase Token Replay Vulnerability:** A legitimate purchase token could be reused indefinitely. The system now correctly invalidates tokens after their first use.
4.  **Insufficient PBKDF2 Iterations:** The key derivation function used an insufficient number of iterations, making encrypted patches more susceptible to brute-force attacks. This has been strengthened.

### Required Actions

To fix these vulnerabilities, users of version **7.0.7** must **upgrade the \`taylored\` tool and regenerate their \`taysell-server\` instance**.

Please follow these steps carefully:

1.  **Upgrade to the Secure Version of \`taylored\`:**
    Open your terminal and run the following command to install the latest version:
    \`\`\`bash
    npm install -g taylored@latest
    \`\`\`
    Verify that you have version 7.0.8 or later.

2.  **Remove the Vulnerable Backend:**
    Navigate to the project directory where you previously generated the backend with v7.0.7 and **completely delete the old \`taysell-server\` directory**.
    \`\`\`bash
    # Back up any customizations if necessary
    rm -rf taysell-server
    \`\`\`

3.  **Generate the New, Secure Backend:**
    From the same directory, run the \`setup-backend\` command again using the upgraded \`taylored\` tool. This will create a new \`taysell-server\` directory with the patched, secure code.
    \`\`\`bash
    taylored setup-backend
    \`\`\`
    Follow the prompts and enter your PayPal credentials and server configuration. **Using a new, strong, and unique \`PATCH_ENCRYPTION_KEY\` is highly recommended.**

4.  **Recreate and Re-upload Commercial Patches:**
    Due to the cryptography improvements, **patches created with version 7.0.7 are not compatible with the new, secure backend**. You must recreate them:
    * For each of your commercial patches, run the \`taylored create-taysell\` command again.
    * Upload the new encrypted files (e.g., \`patch-name.taylored.encrypted\`) to the \`patches/\` directory of your new \`taysell-server\`.

5.  **Launch the New Server:**
    Start your new backend using Docker Compose:
    \`\`\`bash
    cd taysell-server
    docker-compose up --build -d
    \`\`\`

For questions or support, please refer to the official documentation or open an issue on our GitHub repository.

Thank you for your attention to this important update.

## Which versions are affected by GHSA-8g98-m4j9-qww5?

2 open source packages ship an affected version, including taylored.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `taylored` | npm | From 7.0.5 | 7.0.8 |
| `taylored` | npm | From 7.0.5 | 7.0.8 |

## How do I fix GHSA-8g98-m4j9-qww5?

Upgrade taylored to 7.0.8 or later.

## Is GHSA-8g98-m4j9-qww5 being exploited?

There is no known exploitation of GHSA-8g98-m4j9-qww5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8g98-m4j9-qww5 and fix it if it is affected.

What it is: GHSA-8g98-m4j9-qww5 is a path traversal vulnerability in taylored, published on 18 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-8g98-m4j9-qww5 in the wild and no public exploit code.

Affected packages and fixed versions:
- taylored (npm): affected from 7.0.5; fixed in 7.0.8
- taylored (npm): affected from 7.0.5; fixed in 7.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8g98-m4j9-qww5/ (Markdown: https://insights.sbomify.com/GHSA-8g98-m4j9-qww5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8g98-m4j9-qww5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8g98-m4j9-qww5/
Summaries are generated and may contain mistakes; the official description above is the record.
