{"answers":{"affected":"4 open source packages ship an affected version, including amphp/http-server.","exploited":"There is no known exploitation of GHSA-8grv-jq2g-cfhw in the wild and no public exploit code.","fix":"Upgrade amphp/http-server to a fixed version for your release line: 2.1.10 or 3.4.4.","what":"GHSA-8grv-jq2g-cfhw is a denial of service vulnerability in amphp/http-server, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8grv-jq2g-cfhw and fix it if it is affected.\n\nWhat it is: GHSA-8grv-jq2g-cfhw is a denial of service vulnerability in amphp/http-server, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8grv-jq2g-cfhw in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- amphp/http-server (Packagist): affected from 2.0.0-rc1; fixed in 2.1.10\n- amphp/http-server (Packagist): affected from 2.0.0-rc1; fixed in 2.1.10\n- amphp/http-server (Packagist): affected from 3.0.0-beta.1; fixed in 3.4.4\n- amphp/http-server (Packagist): affected from 3.0.0-beta.1; fixed in 3.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/ (Markdown: https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/index.md)","id":"GHSA-8grv-jq2g-cfhw","markdown":"https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/index.md","name":"GHSA-8grv-jq2g-cfhw","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP HTTP server library","requires_auth":"none","summary":"Attackers can cause denial of service in amphp/http-server via HTTP/2 MadeYouReset attacks if HTTP/2 is directly exposed.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `amphp/http-server` prior to `3.4.4` for the 3.x release branch and prior to `2.1.10` for the 2.x release branch are vulnerable to the HTTP/2 \"MadeYouReset\" DoS attack described by CVE-2025-8671 and https://kb.cert.org/vuls/id/767506.\n\nIn versions `3.4.4` and `2.1.10`, stream reset protection has been refactored to account for the number of reset streams within a sliding time window.\n\nNote that your application must expose HTTP/2 connections directly to be affected by this vulnerability. Servers behind a proxy using HTTP/1.x such as nginx are not affected.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"amphp/http-server affected by HTTP/2 DDoS vulnerability","id":"GHSA-8grv-jq2g-cfhw","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["2.1.10"],"introduced":["2.0.0-rc1"],"last_affected":[],"package":"amphp/http-server","purl":null,"source":"GHSA-8grv-jq2g-cfhw"},{"ecosystem":"Packagist","fixed":["2.1.10"],"introduced":["2.0.0-rc1"],"last_affected":[],"package":"amphp/http-server","purl":"pkg:composer/amphp/http-server","source":"GHSA-8grv-jq2g-cfhw"},{"ecosystem":"Packagist","fixed":["3.4.4"],"introduced":["3.0.0-beta.1"],"last_affected":[],"package":"amphp/http-server","purl":null,"source":"GHSA-8grv-jq2g-cfhw"},{"ecosystem":"Packagist","fixed":["3.4.4"],"introduced":["3.0.0-beta.1"],"last_affected":[],"package":"amphp/http-server","purl":"pkg:composer/amphp/http-server","source":"GHSA-8grv-jq2g-cfhw"}],"products":null,"published":"2026-02-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause denial of service in amphp/http-server via HTTP/2 MadeYouReset attacks if HTTP/2 is directly exposed.","url":"https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/"}