# GHSA-8grv-jq2g-cfhw: amphp/http-server affected by HTTP/2 DDoS vulnerability

> Attackers can cause denial of service in amphp/http-server via HTTP/2 MadeYouReset attacks if HTTP/2 is directly exposed.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2026

## What is GHSA-8grv-jq2g-cfhw?

GHSA-8grv-jq2g-cfhw is a denial of service vulnerability in amphp/http-server, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of `amphp/http-server` prior to `3.4.4` for the 3.x release branch and prior to `2.1.10` for the 2.x release branch are vulnerable to the HTTP/2 "MadeYouReset" DoS attack described by CVE-2025-8671 and https://kb.cert.org/vuls/id/767506.

In versions `3.4.4` and `2.1.10`, stream reset protection has been refactored to account for the number of reset streams within a sliding time window.

Note that your application must expose HTTP/2 connections directly to be affected by this vulnerability. Servers behind a proxy using HTTP/1.x such as nginx are not affected.

## Which versions are affected by GHSA-8grv-jq2g-cfhw?

4 open source packages ship an affected version, including amphp/http-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `amphp/http-server` | Packagist | From 2.0.0-rc1 | 2.1.10 |
| `amphp/http-server` | Packagist | From 2.0.0-rc1 | 2.1.10 |
| `amphp/http-server` | Packagist | From 3.0.0-beta.1 | 3.4.4 |
| `amphp/http-server` | Packagist | From 3.0.0-beta.1 | 3.4.4 |

## How do I fix GHSA-8grv-jq2g-cfhw?

Upgrade amphp/http-server to a fixed version for your release line: 2.1.10 or 3.4.4.

## Is GHSA-8grv-jq2g-cfhw being exploited?

There is no known exploitation of GHSA-8grv-jq2g-cfhw in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8grv-jq2g-cfhw and fix it if it is affected.

What it is: GHSA-8grv-jq2g-cfhw is a denial of service vulnerability in amphp/http-server, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-8grv-jq2g-cfhw in the wild and no public exploit code.

Affected packages and fixed versions:
- amphp/http-server (Packagist): affected from 2.0.0-rc1; fixed in 2.1.10
- amphp/http-server (Packagist): affected from 2.0.0-rc1; fixed in 2.1.10
- amphp/http-server (Packagist): affected from 3.0.0-beta.1; fixed in 3.4.4
- amphp/http-server (Packagist): affected from 3.0.0-beta.1; fixed in 3.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/ (Markdown: https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8grv-jq2g-cfhw

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8grv-jq2g-cfhw/
Summaries are generated and may contain mistakes; the official description above is the record.
