{"answers":{"affected":"2 open source packages ship an affected version, including pgp.","exploited":"There is no known exploitation of GHSA-8h58-w33p-wq3g in the wild and no public exploit code.","fix":"Upgrade pgp to 0.19.0 or later.","what":"GHSA-8h58-w33p-wq3g is a denial of service vulnerability in pgp, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8h58-w33p-wq3g and fix it if it is affected.\n\nWhat it is: GHSA-8h58-w33p-wq3g is a denial of service vulnerability in pgp, published on 13 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8h58-w33p-wq3g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgp (crates.io): affected from 0.16.0-alpha.0; fixed in 0.19.0\n- pgp (crates.io): affected from 0.16.0-alpha.0; fixed in 0.19.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8h58-w33p-wq3g/ (Markdown: https://insights.sbomify.com/GHSA-8h58-w33p-wq3g/index.md)","id":"GHSA-8h58-w33p-wq3g","markdown":"https://insights.sbomify.com/GHSA-8h58-w33p-wq3g/index.md","name":"GHSA-8h58-w33p-wq3g","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust PGP library","requires_auth":"none","summary":"An attacker can cause a denial of service by sending deeply nested PGP messages that trigger a stack overflow in the rPGP library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Summary\nPrevious rPGP versions could be caused to crash with a \"stack overflow\" when parsing messages that contain deeply nested message layers, such as messages with many signatures.\n\nrPGP 0.19.0 resolves this issue with a more robust message handling implementation (via https://github.com/rpgp/rpgp/pull/625).\n\n### Impact\nAn attacker could cause applications to crash in rPGP's message parsing subsystem, when applications attempt to ingest messages.\n\n### Attribution\nDiscovered internally during rPGP development, using a fuzz test suite previously contributed by Christian Reitter.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"rPGP affected by crash in message handling for deeply nested messages","id":"GHSA-8h58-w33p-wq3g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":["0.19.0"],"introduced":["0.16.0-alpha.0"],"last_affected":[],"package":"pgp","purl":null,"source":"GHSA-8h58-w33p-wq3g"},{"ecosystem":"crates.io","fixed":["0.19.0"],"introduced":["0.16.0-alpha.0"],"last_affected":[],"package":"pgp","purl":"pkg:cargo/pgp","source":"GHSA-8h58-w33p-wq3g"}],"products":null,"published":"2026-02-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can cause a denial of service by sending deeply nested PGP messages that trigger a stack overflow in the rPGP library.","url":"https://insights.sbomify.com/GHSA-8h58-w33p-wq3g/"}