{"answers":{"affected":"2 open source packages ship an affected version, including express-cart.","exploited":"There is no known exploitation of GHSA-8h8v-6qqm-fwpq in the wild and no public exploit code.","fix":"Upgrade express-cart to 1.1.7 or later.","what":"GHSA-8h8v-6qqm-fwpq is a path traversal vulnerability in express-cart, published on 1 Sep 2020. It can be exploited over the network."},"fix_prompt":"Check this codebase for GHSA-8h8v-6qqm-fwpq and fix it if it is affected.\n\nWhat it is: GHSA-8h8v-6qqm-fwpq is a path traversal vulnerability in express-cart, published on 1 Sep 2020. It can be exploited over the network.\nExploitation: There is no known exploitation of GHSA-8h8v-6qqm-fwpq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- express-cart (npm): affected all versions; fixed in 1.1.7\n- express-cart (npm): affected all versions; fixed in 1.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8h8v-6qqm-fwpq/ (Markdown: https://insights.sbomify.com/GHSA-8h8v-6qqm-fwpq/index.md)","id":"GHSA-8h8v-6qqm-fwpq","markdown":"https://insights.sbomify.com/GHSA-8h8v-6qqm-fwpq/index.md","name":"GHSA-8h8v-6qqm-fwpq","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js cart library","requires_auth":"unknown","summary":"An attacker can exploit a path traversal vulnerability in the express-cart library to read arbitrary files from the server.","user_interaction":"unknown","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `express-cart` before 1.1.7 are vulnerable to Path Traversal.\n\n## Recommendation\n\nUpdate to version 1.1.7 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Path Traversal in express-cart","id":"GHSA-8h8v-6qqm-fwpq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":null,"source":"GHSA-8h8v-6qqm-fwpq"},{"ecosystem":"npm","fixed":["1.1.7"],"introduced":["0"],"last_affected":[],"package":"express-cart","purl":"pkg:npm/express-cart","source":"GHSA-8h8v-6qqm-fwpq"}],"products":null,"published":"2020-09-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can exploit a path traversal vulnerability in the express-cart library to read arbitrary files from the server.","url":"https://insights.sbomify.com/GHSA-8h8v-6qqm-fwpq/"}