{"answers":{"affected":"4 open source packages ship an affected version, including require-node.","exploited":"There is no known exploitation of GHSA-8j6j-4h2c-c65p in the wild and no public exploit code.","fix":"Upgrade require-node to a fixed version for your release line: 1.3.4 or 2.0.4.","what":"GHSA-8j6j-4h2c-c65p is a command injection vulnerability in require-node, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8j6j-4h2c-c65p and fix it if it is affected.\n\nWhat it is: GHSA-8j6j-4h2c-c65p is a command injection vulnerability in require-node, published on 3 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8j6j-4h2c-c65p in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- require-node (npm): affected all versions; fixed in 1.3.4\n- require-node (npm): affected all versions; fixed in 1.3.4\n- require-node (npm): affected from 2.0.0; fixed in 2.0.4\n- require-node (npm): affected from 2.0.0; fixed in 2.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8j6j-4h2c-c65p/ (Markdown: https://insights.sbomify.com/GHSA-8j6j-4h2c-c65p/index.md)","id":"GHSA-8j6j-4h2c-c65p","markdown":"https://insights.sbomify.com/GHSA-8j6j-4h2c-c65p/index.md","name":"GHSA-8j6j-4h2c-c65p","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js require library","requires_auth":"none","summary":"Attackers can execute arbitrary OS commands on the server by injecting malicious payloads into the require-node endpoint request body.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of `require-node` prior to 1.3.4 for 1.x and 2.0.4 for 2.x are vulnerable to Arbitrary Code Execution. The package fails to sanitize requests to the `require-node` endpoint, allowing attackers to execute arbitrary code in the server through the injection of OS commands in the request body.\n\n## Recommendation\n\n- If you are using 1.x, upgrade to version 1.3.4 or later.\n- If you are using 2.x, upgrade to version 2.0.4 or later.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Arbitrary Code Execution in require-node","id":"GHSA-8j6j-4h2c-c65p","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"require-node","purl":null,"source":"GHSA-8j6j-4h2c-c65p"},{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"require-node","purl":"pkg:npm/require-node","source":"GHSA-8j6j-4h2c-c65p"},{"ecosystem":"npm","fixed":["2.0.4"],"introduced":["2.0.0"],"last_affected":[],"package":"require-node","purl":null,"source":"GHSA-8j6j-4h2c-c65p"},{"ecosystem":"npm","fixed":["2.0.4"],"introduced":["2.0.0"],"last_affected":[],"package":"require-node","purl":"pkg:npm/require-node","source":"GHSA-8j6j-4h2c-c65p"}],"products":null,"published":"2020-09-03","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary OS commands on the server by injecting malicious payloads into the require-node endpoint request body.","url":"https://insights.sbomify.com/GHSA-8j6j-4h2c-c65p/"}