GHSA-8jh9-wqpf-q52c sweetalert2 v8.19.1 and above contains hidden functionality
The sweetalert2 library contains hidden audio/video functionality introduced by the maintainer, requiring an upgrade to remove this unwanted behavior.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-8jh9-wqpf-q52c?
GHSA-8jh9-wqpf-q52c is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
sweetalert2 versions 8.19.1 and up until 9.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions below 8.19.1.
Workaround
Users who are unable to update to the fixed version (11.22.4) can use package versions 8.19.0 and below, as they do not contain the hidden functionality.
Which versions are affected by GHSA-8jh9-wqpf-q52c?
2 open source packages ship an affected version, including sweetalert2.
| Package | Affected | Fixed in |
|---|---|---|
sweetalert2 npm | From 8.19.1 | 11.22.4 |
sweetalert2 npm | From 8.19.1 | 11.22.4 |
How do I fix GHSA-8jh9-wqpf-q52c?
Upgrade sweetalert2 to 11.22.4 or later.
Is GHSA-8jh9-wqpf-q52c being exploited?
There is no known exploitation of GHSA-8jh9-wqpf-q52c in the wild and no public exploit code.