# GHSA-8jh9-wqpf-q52c: sweetalert2 v8.19.1 and above contains hidden functionality

> The sweetalert2 library contains hidden audio/video functionality introduced by the maintainer, requiring an upgrade to remove this unwanted behavior.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022

## What is GHSA-8jh9-wqpf-q52c?

GHSA-8jh9-wqpf-q52c is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

`sweetalert2` versions 8.19.1 and up until 9.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions below 8.19.1.

### Workaround
Users who are unable to update to the fixed version (11.22.4) can use package versions 8.19.0 and below, as they do not contain the hidden functionality.

## Which versions are affected by GHSA-8jh9-wqpf-q52c?

2 open source packages ship an affected version, including sweetalert2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sweetalert2` | npm | From 8.19.1 | 11.22.4 |
| `sweetalert2` | npm | From 8.19.1 | 11.22.4 |

## How do I fix GHSA-8jh9-wqpf-q52c?

Upgrade sweetalert2 to 11.22.4 or later.

## Is GHSA-8jh9-wqpf-q52c being exploited?

There is no known exploitation of GHSA-8jh9-wqpf-q52c in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8jh9-wqpf-q52c and fix it if it is affected.

What it is: GHSA-8jh9-wqpf-q52c is a vulnerability in sweetalert2, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-8jh9-wqpf-q52c in the wild and no public exploit code.

Affected packages and fixed versions:
- sweetalert2 (npm): affected from 8.19.1; fixed in 11.22.4
- sweetalert2 (npm): affected from 8.19.1; fixed in 11.22.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8jh9-wqpf-q52c/ (Markdown: https://insights.sbomify.com/GHSA-8jh9-wqpf-q52c/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8jh9-wqpf-q52c

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8jh9-wqpf-q52c/
Summaries are generated and may contain mistakes; the official description above is the record.
