{"answers":{"affected":"2 open source packages ship an affected version, including amphp/http-client.","exploited":"There is no known exploitation of GHSA-8jp9-mpv9-98rj in the wild and no public exploit code.","fix":"Upgrade amphp/http-client to 4.4.0 or later.","what":"GHSA-8jp9-mpv9-98rj is a vulnerability in amphp/http-client, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8jp9-mpv9-98rj and fix it if it is affected.\n\nWhat it is: GHSA-8jp9-mpv9-98rj is a vulnerability in amphp/http-client, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8jp9-mpv9-98rj in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- amphp/http-client (Packagist): affected from 4.0.0; fixed in 4.4.0\n- amphp/http-client (Packagist): affected from 4.0.0; fixed in 4.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8jp9-mpv9-98rj/ (Markdown: https://insights.sbomify.com/GHSA-8jp9-mpv9-98rj/index.md)","id":"GHSA-8jp9-mpv9-98rj","markdown":"https://insights.sbomify.com/GHSA-8jp9-mpv9-98rj/index.md","name":"GHSA-8jp9-mpv9-98rj","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP client library","requires_auth":"none","summary":"An attacker can leak sensitive request headers to a different host during cross-domain redirects in the amphp/http-client library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"amphp/http-client has a security weakness that might leak sensitive request headers from the initial request to the redirected host on cross-domain redirects, which were not removed correctly. `Message::setHeaders` does not replace the entire set of headers, but only operates on the headers matching the given array keys.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"amphp/http-client Header leakage on cross-domain redirects","id":"GHSA-8jp9-mpv9-98rj","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["4.4.0"],"introduced":["4.0.0"],"last_affected":[],"package":"amphp/http-client","purl":null,"source":"GHSA-8jp9-mpv9-98rj"},{"ecosystem":"Packagist","fixed":["4.4.0"],"introduced":["4.0.0"],"last_affected":[],"package":"amphp/http-client","purl":"pkg:composer/amphp/http-client","source":"GHSA-8jp9-mpv9-98rj"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can leak sensitive request headers to a different host during cross-domain redirects in the amphp/http-client library.","url":"https://insights.sbomify.com/GHSA-8jp9-mpv9-98rj/"}