# GHSA-8pfh-mm2g-hmc3: Authenticated Server Side Request Forgery

> Authenticated attackers can exploit Server Side Request Forgery in Shopware to access internal resources or bypass security controls.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Dec 2020

## What is GHSA-8pfh-mm2g-hmc3?

GHSA-8pfh-mm2g-hmc3 is a server-side request forgery vulnerability in shopware/core, published on 21 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

### Impact
Authenticated Server Side Request Forgery

### Patches
We recommend to update to the current version 6.3.4.1. You can get the update to 6.3.4.1 regularly via the Auto-Updater or directly via the download overview.

https://www.shopware.com/en/download/#shopware-6

### Workarounds
For older versions of 6.1 and 6.2 the corresponding changes are also available via plugin:

https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659

### For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-12-2020

### Credits
We would like to thank <a rel="noopener" href="https://reqon.nl">REQON B.V.</a> for reporting this issue.

## Which versions are affected by GHSA-8pfh-mm2g-hmc3?

4 open source packages ship an affected version, including shopware/core and shopware/platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.3.4.1 |
| `shopware/core` | Packagist | All versions | 6.3.4.1 |
| `shopware/platform` | Packagist | All versions | 6.3.4.1 |
| `shopware/platform` | Packagist | All versions | 6.3.4.1 |

## How do I fix GHSA-8pfh-mm2g-hmc3?

Upgrade shopware/core to 6.3.4.1 or later.

## Is GHSA-8pfh-mm2g-hmc3 being exploited?

There is no known exploitation of GHSA-8pfh-mm2g-hmc3 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8pfh-mm2g-hmc3 and fix it if it is affected.

What it is: GHSA-8pfh-mm2g-hmc3 is a server-side request forgery vulnerability in shopware/core, published on 21 Dec 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-8pfh-mm2g-hmc3 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.3.4.1
- shopware/core (Packagist): affected all versions; fixed in 6.3.4.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.4.1
- shopware/platform (Packagist): affected all versions; fixed in 6.3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8pfh-mm2g-hmc3/ (Markdown: https://insights.sbomify.com/GHSA-8pfh-mm2g-hmc3/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8pfh-mm2g-hmc3

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8pfh-mm2g-hmc3/
Summaries are generated and may contain mistakes; the official description above is the record.
