GHSA-8pqq-224h-x875 ogham-mcp had credentials embedded in published PyPI sdists -- Neon postgres URLs and Voyage API key
Not scored
Published
Check this codebase for GHSA-8pqq-224h-x875 and fix it if it is affected.
What it is: GHSA-8pqq-224h-x875 is a vulnerability in ogham-mcp, published on 5 May 2026.
Exploitation: There is no known exploitation of GHSA-8pqq-224h-x875 in the wild and no public exploit code.
Affected packages and fixed versions:
- ogham-mcp (PyPI): affected from 0.6.3; fixed in 0.11.1
- ogham-mcp (PyPI): affected from 0.6.3; fixed in 0.11.1
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/GHSA-8pqq-224h-x875/ (Markdown: https://insights.sbomify.com/GHSA-8pqq-224h-x875/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is GHSA-8pqq-224h-x875?
GHSA-8pqq-224h-x875 is a vulnerability in ogham-mcp, published on 5 May 2026.
Official description
Summary
Between 2026-02 and 2026-04-24 a total of 22 public PyPI sdists of ogham-mcp contained development credentials embedded in source files. All credentials have since been rotated on the respective providers. No known exploitation. Upgrade to v0.11.1 to get a clean release.
What was leaked
| Credential | Location in sdist | Vulnerable range | Count |
|---|---|---|---|
| 3x Neon postgres URLs with passwords (US / EU / AP development databases) | top-level Makefile (NEON_US, NEON_EU, NEON_AP vars) | >=0.6.5, <0.11.0 | 21 sdists |
1x Voyage AI API key (pa-...) | tests/test_hooks.py::test_mask_secrets_key_value – test fixture that fed a real key into the redaction-function tester | >=0.6.3, <0.11.1 | 22 sdists |
Impact
- Primary risk: any consumer of the affected sdists could have extracted the credentials and used them. The Neon URLs pointed at development databases; the Voyage key was a rate-limited API key.
- Observed exploitation: none detected. Audit logs on both providers were reviewed post-rotation.
- Remediation on our side:
- Neon passwords for all three regions rotated.
- Voyage API key rotated.
- All affected versions yanked from PyPI (v0.3.0 through v0.10.4 yanked on 2026-04-24; v0.11.0 pending yank after this advisory).
- v0.11.0 removed the Neon URLs and introduced
make publish-checkwhich scans every sdist for credential patterns before upload. - v0.11.1 scrubs the Voyage key from the test fixture and excludes
benchmarks/,docs/,research/,extras/, and**/*.env*from all future sdists via explicit hatchling sdist include/exclude inpyproject.toml.
Action for users
- If users installed any version from
v0.3.0throughv0.11.0, upgrade to v0.11.1 immediately:pip install --upgrade "ogham-mcp>=0.11.1" - Users do not need to rotate anything on their end. The leaked credentials were owned by the project maintainer, not by users.
Credit
Discovered during an internal pre-release audit on 2026-04-24 while preparing v0.11.1.
Which versions are affected by GHSA-8pqq-224h-x875?
2 open source packages ship an affected version, including ogham-mcp.
| Package | Affected | Fixed in |
|---|---|---|
ogham-mcp PyPI | From 0.6.3 | 0.11.1 |
ogham-mcp PyPI | From 0.6.3 | 0.11.1 |
How do I fix GHSA-8pqq-224h-x875?
Upgrade ogham-mcp to 0.11.1 or later.
Is GHSA-8pqq-224h-x875 being exploited?
There is no known exploitation of GHSA-8pqq-224h-x875 in the wild and no public exploit code.