{"answers":{"affected":"2 open source packages ship an affected version, including streamlit.","exploited":"There is no known exploitation of GHSA-8qw9-gf7w-42x5 in the wild and no public exploit code.","fix":"Upgrade streamlit to 1.30.0 or later.","what":"GHSA-8qw9-gf7w-42x5 is a vulnerability in streamlit, published on 12 Jan 2024."},"fix_prompt":"Check this codebase for GHSA-8qw9-gf7w-42x5 and fix it if it is affected.\n\nWhat it is: GHSA-8qw9-gf7w-42x5 is a vulnerability in streamlit, published on 12 Jan 2024. \nExploitation: There is no known exploitation of GHSA-8qw9-gf7w-42x5 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- streamlit (PyPI): affected from 0.63.0; fixed in 1.30.0\n- streamlit (PyPI): affected from 0.63.0; fixed in 1.30.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/ (Markdown: https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/index.md)","id":"GHSA-8qw9-gf7w-42x5","markdown":"https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/index.md","name":"GHSA-8qw9-gf7w-42x5","record":{"aliases":[],"analysis":null,"analysis_generated_by":null,"assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\n\nThe initial vulnerability identified in Streamlit apps using custom components, allowing for directory traversal attacks, was addressed in version 1.11.1. However, a minor issue persisted, which could still potentially expose certain files on the server file-system under specific conditions.\n\n### Patches\n\nWe released an update in version 1.30.0 to further tighten security measures. Users are strongly advised to update to version 1.30.0 immediately for optimal security.\n\n### Workarounds\n\nNo additional workarounds are necessary once the update to version 1.30.0 is applied.\n\n### For more information\n\nIf you have any questions or comments about this advisory:\n* Email us at [security@streamlit.io](mailto:security@streamlit.io)","ecosystems":["PyPI"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Minor fix to previous patch for CVE-2022-35918","id":"GHSA-8qw9-gf7w-42x5","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"PyPI","fixed":["1.30.0"],"introduced":["0.63.0"],"last_affected":[],"package":"streamlit","purl":null,"source":"GHSA-8qw9-gf7w-42x5"},{"ecosystem":"PyPI","fixed":["1.30.0"],"introduced":["0.63.0"],"last_affected":[],"package":"streamlit","purl":"pkg:pypi/streamlit","source":"GHSA-8qw9-gf7w-42x5"}],"products":null,"published":"2024-01-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":null,"url":"https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/"}