# GHSA-8qw9-gf7w-42x5: Minor fix to previous patch for CVE-2022-35918


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Jan 2024

## What is GHSA-8qw9-gf7w-42x5?

GHSA-8qw9-gf7w-42x5 is a vulnerability in streamlit, published on 12 Jan 2024. 

### Official description

### Impact

The initial vulnerability identified in Streamlit apps using custom components, allowing for directory traversal attacks, was addressed in version 1.11.1. However, a minor issue persisted, which could still potentially expose certain files on the server file-system under specific conditions.

### Patches

We released an update in version 1.30.0 to further tighten security measures. Users are strongly advised to update to version 1.30.0 immediately for optimal security.

### Workarounds

No additional workarounds are necessary once the update to version 1.30.0 is applied.

### For more information

If you have any questions or comments about this advisory:
* Email us at [security@streamlit.io](mailto:security@streamlit.io)

## Which versions are affected by GHSA-8qw9-gf7w-42x5?

2 open source packages ship an affected version, including streamlit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `streamlit` | PyPI | From 0.63.0 | 1.30.0 |
| `streamlit` | PyPI | From 0.63.0 | 1.30.0 |

## How do I fix GHSA-8qw9-gf7w-42x5?

Upgrade streamlit to 1.30.0 or later.

## Is GHSA-8qw9-gf7w-42x5 being exploited?

There is no known exploitation of GHSA-8qw9-gf7w-42x5 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-8qw9-gf7w-42x5 and fix it if it is affected.

What it is: GHSA-8qw9-gf7w-42x5 is a vulnerability in streamlit, published on 12 Jan 2024. 
Exploitation: There is no known exploitation of GHSA-8qw9-gf7w-42x5 in the wild and no public exploit code.

Affected packages and fixed versions:
- streamlit (PyPI): affected from 0.63.0; fixed in 1.30.0
- streamlit (PyPI): affected from 0.63.0; fixed in 1.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/ (Markdown: https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-8qw9-gf7w-42x5

---
From sbomify Insights: https://insights.sbomify.com/GHSA-8qw9-gf7w-42x5/
Summaries are generated and may contain mistakes; the official description above is the record.
