GHSA-8qxh-2gh8-r923 cheqd-node subject to Cosmos SDK "Barberry" vulnerability
Attackers can exploit vesting account logic to halt the blockchain or modify state, requiring node operators to upgrade.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-8qxh-2gh8-r923?
GHSA-8qxh-2gh8-r923 is a vulnerability in github.com/cheqd/cheqd-node, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Impact
This vulnerability dubbed "Barberry" affects the Cosmos SDK framework used by cheqd-node as base.
It impacts the way Cosmos SDK handles vesting accounts, and can therefore be a high-impact vulnerability for any network running the framework.
There is no vulnerability in the DID/resource modules for cheqd-node.
Patches
Node operators are requested to upgrade to cheqd-node v1.4.4. This is not a state-breaking release and does not require a coordinated upgrade across all node operators.
This vulnerability was patched in Cosmos SDK v0.46.13. Since this version switches to Go v1.19 and also changes the namespace of many Cosmos protobuf packages, the Barberry fix was backported to cheqd's fork of Cosmos SDK.
Mitigation
When at least ~33% of the voting power of the network has deployed the recommended version of the software, any attack would be unsuccessful but cause a chain halt.
Once at least ~67% of the voting power of the network has deployed recommended version of the software, the attack would be unsuccessful without a chain halt.
Workarounds
No. Node operators are recommended to upgrade to the latest release version.
References
Which versions are affected by GHSA-8qxh-2gh8-r923?
2 open source packages ship an affected version, including github.com/cheqd/cheqd-node.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cheqd/cheqd-node Go | All versions | 1.4.4 |
github.com/cheqd/cheqd-node Go | All versions | 1.4.4 |
How do I fix GHSA-8qxh-2gh8-r923?
Upgrade github.com/cheqd/cheqd-node to 1.4.4 or later.
Is GHSA-8qxh-2gh8-r923 being exploited?
There is no known exploitation of GHSA-8qxh-2gh8-r923 in the wild and no public exploit code.