{"answers":{"affected":"2 open source packages ship an affected version, including github.com/cheqd/cheqd-node.","exploited":"There is no known exploitation of GHSA-8qxh-2gh8-r923 in the wild and no public exploit code.","fix":"Upgrade github.com/cheqd/cheqd-node to 1.4.4 or later.","what":"GHSA-8qxh-2gh8-r923 is a vulnerability in github.com/cheqd/cheqd-node, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8qxh-2gh8-r923 and fix it if it is affected.\n\nWhat it is: GHSA-8qxh-2gh8-r923 is a vulnerability in github.com/cheqd/cheqd-node, published on 12 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8qxh-2gh8-r923 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/cheqd/cheqd-node (Go): affected all versions; fixed in 1.4.4\n- github.com/cheqd/cheqd-node (Go): affected all versions; fixed in 1.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8qxh-2gh8-r923/ (Markdown: https://insights.sbomify.com/GHSA-8qxh-2gh8-r923/index.md)","id":"GHSA-8qxh-2gh8-r923","markdown":"https://insights.sbomify.com/GHSA-8qxh-2gh8-r923/index.md","name":"GHSA-8qxh-2gh8-r923","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Blockchain node software","requires_auth":"low_privilege","summary":"Attackers can exploit vesting account logic to halt the blockchain or modify state, requiring node operators to upgrade.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThis [vulnerability dubbed \"Barberry\" affects the Cosmos SDK framework](https://forum.cosmos.network/t/cosmos-sdk-security-advisory-barberry/10825) used by `cheqd-node` as base.\n\nIt impacts the way Cosmos SDK handles vesting accounts, and can therefore be a high-impact vulnerability for any network running the framework.\n\nThere is no vulnerability in the DID/resource modules for `cheqd-node`.\n\n### Patches\nNode operators are requested to upgrade to [cheqd-node v1.4.4](https://github.com/cheqd/cheqd-node/releases/tag/v1.4.4). This is not a state-breaking release and does not require a coordinated upgrade across all node operators.\n\nThis vulnerability was patched in [Cosmos SDK v0.46.13](https://github.com/cosmos/cosmos-sdk/releases/tag/v0.46.13). Since this version switches to Go v1.19 and also changes the namespace of many Cosmos protobuf packages, the Barberry fix was [backported to cheqd's fork of Cosmos SDK](https://github.com/cheqd/cosmos-sdk/releases/tag/v0.46.10-barberry).\n\n### Mitigation\nWhen at least ~**33**% of the voting power of the network has deployed the recommended version of the software, any attack would be unsuccessful but cause a chain halt.\n\nOnce at least ~**67**% of the voting power of the network has deployed recommended version of the software, the attack would be unsuccessful _without_ a chain halt.\n\n### Workarounds\nNo. Node operators are recommended to upgrade to the latest release version.\n\n### References\n- [\"Barberry\" vulnerability security advisory](https://forum.cosmos.network/t/cosmos-sdk-security-advisory-barberry/10825)\n- [Cosmos SDK v0.46.13 release notes](https://github.com/cosmos/cosmos-sdk/releases/tag/v0.46.13)","ecosystems":["Go"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"cheqd-node subject to Cosmos SDK \"Barberry\" vulnerability","id":"GHSA-8qxh-2gh8-r923","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Go","product":null,"products":[],"type":"business_logic","year":"2023"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Go","fixed":["1.4.4"],"introduced":["0"],"last_affected":[],"package":"github.com/cheqd/cheqd-node","purl":null,"source":"GHSA-8qxh-2gh8-r923"},{"ecosystem":"Go","fixed":["1.4.4"],"introduced":["0"],"last_affected":[],"package":"github.com/cheqd/cheqd-node","purl":"pkg:golang/github.com/cheqd/cheqd-node","source":"GHSA-8qxh-2gh8-r923"}],"products":null,"published":"2023-06-12","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can exploit vesting account logic to halt the blockchain or modify state, requiring node operators to upgrade.","url":"https://insights.sbomify.com/GHSA-8qxh-2gh8-r923/"}