GHSA-8rgj-285w-qcq4 Unknown vulnerability in Coinbase Wallet SDK

Not scored Published

Outdated Coinbase Wallet SDK versions contain an unspecified vulnerability that does not directly impact keys or funds.

Exploited in the wild
Not known
Login needed
Not stated
Attackable
Not stated
Victim action needed
Not stated
Fix
Available

What is GHSA-8rgj-285w-qcq4?

GHSA-8rgj-285w-qcq4 is a vulnerability in @coinbase/wallet-sdk, published on 10 Feb 2025.

Official description

Impact

There is a security vulnerability in outdated versions of Coinbase Wallet SDK. This does not directly affect users' keys, smart contracts, or funds.

Patches

Please update to version >= 4.3.0.

Which versions are affected by GHSA-8rgj-285w-qcq4?

2 open source packages ship an affected version, including @coinbase/wallet-sdk.

PackageAffectedFixed in
@coinbase/wallet-sdk npmFrom 4.0.0-beta.04.3.0
@coinbase/wallet-sdk npmFrom 4.0.0-beta.04.3.0

How do I fix GHSA-8rgj-285w-qcq4?

Upgrade @coinbase/wallet-sdk to 4.3.0 or later.

Is GHSA-8rgj-285w-qcq4 being exploited?

There is no known exploitation of GHSA-8rgj-285w-qcq4 in the wild and no public exploit code.

Sources

Is GHSA-8rgj-285w-qcq4 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free