{"answers":{"affected":"2 open source packages ship an affected version, including @coinbase/wallet-sdk.","exploited":"There is no known exploitation of GHSA-8rgj-285w-qcq4 in the wild and no public exploit code.","fix":"Upgrade @coinbase/wallet-sdk to 4.3.0 or later.","what":"GHSA-8rgj-285w-qcq4 is a vulnerability in @coinbase/wallet-sdk, published on 10 Feb 2025."},"fix_prompt":"Check this codebase for GHSA-8rgj-285w-qcq4 and fix it if it is affected.\n\nWhat it is: GHSA-8rgj-285w-qcq4 is a vulnerability in @coinbase/wallet-sdk, published on 10 Feb 2025. \nExploitation: There is no known exploitation of GHSA-8rgj-285w-qcq4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @coinbase/wallet-sdk (npm): affected from 4.0.0-beta.0; fixed in 4.3.0\n- @coinbase/wallet-sdk (npm): affected from 4.0.0-beta.0; fixed in 4.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8rgj-285w-qcq4/ (Markdown: https://insights.sbomify.com/GHSA-8rgj-285w-qcq4/index.md)","id":"GHSA-8rgj-285w-qcq4","markdown":"https://insights.sbomify.com/GHSA-8rgj-285w-qcq4/index.md","name":"GHSA-8rgj-285w-qcq4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"unknown","non_default_config":false,"product_category":"Coinbase Wallet SDK","requires_auth":"unknown","summary":"Outdated Coinbase Wallet SDK versions contain an unspecified vulnerability that does not directly impact keys or funds.","user_interaction":"unknown","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nThere is a security vulnerability in outdated versions of Coinbase Wallet SDK. This does not directly affect users' keys, smart contracts, or funds.\n\n### Patches\nPlease update to version \u003e= 4.3.0.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Unknown vulnerability in Coinbase Wallet SDK","id":"GHSA-8rgj-285w-qcq4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["4.3.0"],"introduced":["4.0.0-beta.0"],"last_affected":[],"package":"@coinbase/wallet-sdk","purl":null,"source":"GHSA-8rgj-285w-qcq4"},{"ecosystem":"npm","fixed":["4.3.0"],"introduced":["4.0.0-beta.0"],"last_affected":[],"package":"@coinbase/wallet-sdk","purl":"pkg:npm/%40coinbase/wallet-sdk","source":"GHSA-8rgj-285w-qcq4"}],"products":null,"published":"2025-02-10","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Outdated Coinbase Wallet SDK versions contain an unspecified vulnerability that does not directly impact keys or funds.","url":"https://insights.sbomify.com/GHSA-8rgj-285w-qcq4/"}