{"answers":{"affected":"2 open source packages ship an affected version, including amphp/http.","exploited":"There is no known exploitation of GHSA-8v5x-6vv5-jv4g in the wild and no public exploit code.","fix":"Upgrade amphp/http to 1.0.1 or later.","what":"GHSA-8v5x-6vv5-jv4g is a vulnerability in amphp/http, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8v5x-6vv5-jv4g and fix it if it is affected.\n\nWhat it is: GHSA-8v5x-6vv5-jv4g is a vulnerability in amphp/http, published on 15 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8v5x-6vv5-jv4g in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- amphp/http (Packagist): affected all versions; fixed in 1.0.1\n- amphp/http (Packagist): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8v5x-6vv5-jv4g/ (Markdown: https://insights.sbomify.com/GHSA-8v5x-6vv5-jv4g/index.md)","id":"GHSA-8v5x-6vv5-jv4g","markdown":"https://insights.sbomify.com/GHSA-8v5x-6vv5-jv4g/index.md","name":"GHSA-8v5x-6vv5-jv4g","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP library","requires_auth":"none","summary":"Attackers can inject invalid Host headers in amphp/http, potentially leading to cache poisoning or routing issues.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"amphp/http versions before 1.0.1 allows an attacker to supply invalid input in the Host header which may lead to various type of Host header injection attacks.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"amphp/http Host Header Injection vulnerability","id":"GHSA-8v5x-6vv5-jv4g","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"amphp/http","purl":null,"source":"GHSA-8v5x-6vv5-jv4g"},{"ecosystem":"Packagist","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"amphp/http","purl":"pkg:composer/amphp/http","source":"GHSA-8v5x-6vv5-jv4g"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can inject invalid Host headers in amphp/http, potentially leading to cache poisoning or routing issues.","url":"https://insights.sbomify.com/GHSA-8v5x-6vv5-jv4g/"}