GHSA-8vfw-v2jv-9hwc Reflected cross-site scripting in development mode handler in Vaadin
Attackers can execute arbitrary JavaScript in a victim's browser via a crafted URL when Vaadin development mode is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-8vfw-v2jv-9hwc?
GHSA-8vfw-v2jv-9hwc is a cross-site scripting vulnerability in com.vaadin:flow-server, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
Which versions are affected by GHSA-8vfw-v2jv-9hwc?
4 open source packages ship an affected version, including com.vaadin:flow-server.
| Package | Affected | Fixed in |
|---|---|---|
com.vaadin:flow-server Maven | From 2.0.0 | 2.6.2 |
com.vaadin:flow-server Maven | From 2.0.0 | 2.6.2 |
com.vaadin:flow-server Maven | From 3.0.0 | 6.0.10 |
com.vaadin:flow-server Maven | From 3.0.0 | 6.0.10 |
How do I fix GHSA-8vfw-v2jv-9hwc?
Upgrade com.vaadin:flow-server to a fixed version for your release line: 2.6.2 or 6.0.10.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-8vfw-v2jv-9hwc being exploited?
There is no known exploitation of GHSA-8vfw-v2jv-9hwc in the wild and no public exploit code.