{"answers":{"affected":"4 open source packages ship an affected version, including com.vaadin:flow-server.","exploited":"There is no known exploitation of GHSA-8vfw-v2jv-9hwc in the wild and no public exploit code.","fix":"Upgrade com.vaadin:flow-server to a fixed version for your release line: 2.6.2 or 6.0.10.","what":"GHSA-8vfw-v2jv-9hwc is a cross-site scripting vulnerability in com.vaadin:flow-server, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-8vfw-v2jv-9hwc and fix it if it is affected.\n\nWhat it is: GHSA-8vfw-v2jv-9hwc is a cross-site scripting vulnerability in com.vaadin:flow-server, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-8vfw-v2jv-9hwc in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.vaadin:flow-server (Maven): affected from 2.0.0; fixed in 2.6.2\n- com.vaadin:flow-server (Maven): affected from 2.0.0; fixed in 2.6.2\n- com.vaadin:flow-server (Maven): affected from 3.0.0; fixed in 6.0.10\n- com.vaadin:flow-server (Maven): affected from 3.0.0; fixed in 6.0.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8vfw-v2jv-9hwc/ (Markdown: https://insights.sbomify.com/GHSA-8vfw-v2jv-9hwc/index.md)","id":"GHSA-8vfw-v2jv-9hwc","markdown":"https://insights.sbomify.com/GHSA-8vfw-v2jv-9hwc/index.md","name":"GHSA-8vfw-v2jv-9hwc","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Vaadin Java library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in a victim's browser via a crafted URL when Vaadin development mode is enabled.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"URL encoding error in development mode handler in `com.vaadin:flow-server` versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.\n\n- https://vaadin.com/security/cve-2021-33604","ecosystems":["Maven"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Reflected cross-site scripting in development mode handler in Vaadin","id":"GHSA-8vfw-v2jv-9hwc","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Maven","fixed":["2.6.2"],"introduced":["2.0.0"],"last_affected":[],"package":"com.vaadin:flow-server","purl":null,"source":"GHSA-8vfw-v2jv-9hwc"},{"ecosystem":"Maven","fixed":["2.6.2"],"introduced":["2.0.0"],"last_affected":[],"package":"com.vaadin:flow-server","purl":"pkg:maven/com.vaadin/flow-server","source":"GHSA-8vfw-v2jv-9hwc"},{"ecosystem":"Maven","fixed":["6.0.10"],"introduced":["3.0.0"],"last_affected":[],"package":"com.vaadin:flow-server","purl":null,"source":"GHSA-8vfw-v2jv-9hwc"},{"ecosystem":"Maven","fixed":["6.0.10"],"introduced":["3.0.0"],"last_affected":[],"package":"com.vaadin:flow-server","purl":"pkg:maven/com.vaadin/flow-server","source":"GHSA-8vfw-v2jv-9hwc"}],"products":null,"published":"2021-06-28","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can execute arbitrary JavaScript in a victim's browser via a crafted URL when Vaadin development mode is enabled.","url":"https://insights.sbomify.com/GHSA-8vfw-v2jv-9hwc/"}