GHSA-8w54-22w9-3g8f Cross-site Scripting and Open Redirect in Products.CMFPlone
Cache poisoning allows attackers to inject XSS and open redirects into Plone image views, affecting visitors who access the poisoned cached page.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is GHSA-8w54-22w9-3g8f?
GHSA-8w54-22w9-3g8f is a cross-site scripting vulnerability in Products.CMFPlone, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Impact
Plone is vulnerable to reflected cross site scripting and open redirect when an attacker can get a compromised version of the image_view_fullscreen page in a cache, for example in Varnish. The technique is known as cache poisoning. Any later visitor can get redirected when clicking on a link on this page. Usually only anonymous users are affected, but this depends on your cache settings.
Patches
No patch is available for the Products.CMFPlone 4 series. Versions 5.0 and higher are not affected, but two other packages used by these versions are affected.
plone.app.contenttypes has the same problem in all versions, see advisory.
In Plone 5.0-5.2, the default Products.ATContentTypes version has the same problem. See advisory.
Plone 5.2.7 and 6.0.0a3 will be released today and will include these fixes.
For all unpatched versions of the three packages, you can use the following workaround.
Workaround
Make sure the image_view_fullscreen page is not stored in the cache. In Plone:
- Login as Manager and go to Site Setup.
- Go to the 'Caching' control panel. If this does not exist, or 'Enable caching' is not checked, you should normally not be vulnerable.
- Click on the tab 'Caching operations'.
- Under 'Legacy template mappings' locate the ruleset 'Content item view'.
- From the last column ('Templates') remove 'image_view_fullscreen'.
- Click on Save.
Reporter
This vulnerability was responsibly disclosed to the Plone Security Team by Gustav Hansen, F-Secure Consulting. Thank you!
For more information
If you have any questions or comments about this advisory, email us at [email protected] This is also the correct address to use when you want to report a possible vulnerability. See our security report policy.
Which versions are affected by GHSA-8w54-22w9-3g8f?
2 open source packages ship an affected version, including Products.CMFPlone and products-cmfplone.
| Package | Affected | Fixed in |
|---|---|---|
Products.CMFPlone PyPI | All versions | 5.0.0 |
products-cmfplone PyPI | All versions | 5.0.0 |
How do I fix GHSA-8w54-22w9-3g8f?
Upgrade Products.CMFPlone to 5.0.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is GHSA-8w54-22w9-3g8f being exploited?
There is no known exploitation of GHSA-8w54-22w9-3g8f in the wild and no public exploit code.