{"answers":{"affected":"2 open source packages ship an affected version, including aws-advanced-nodejs-wrapper.","exploited":"There is no known exploitation of GHSA-8wj8-cfxr-9374 in the wild and no public exploit code.","fix":"Upgrade aws-advanced-nodejs-wrapper to 2.0.1 or later.","what":"GHSA-8wj8-cfxr-9374 is a vulnerability in aws-advanced-nodejs-wrapper, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8wj8-cfxr-9374 and fix it if it is affected.\n\nWhat it is: GHSA-8wj8-cfxr-9374 is a vulnerability in aws-advanced-nodejs-wrapper, published on 13 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8wj8-cfxr-9374 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-advanced-nodejs-wrapper (npm): affected all versions; fixed in 2.0.1\n- aws-advanced-nodejs-wrapper (npm): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8wj8-cfxr-9374/ (Markdown: https://insights.sbomify.com/GHSA-8wj8-cfxr-9374/index.md)","id":"GHSA-8wj8-cfxr-9374","markdown":"https://insights.sbomify.com/GHSA-8wj8-cfxr-9374/index.md","name":"GHSA-8wj8-cfxr-9374","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AWS NodeJS Wrapper","requires_auth":"low_privilege","summary":"A low-privilege user can escalate to rds_superuser role in Aurora PostgreSQL via a crafted function in the AWS NodeJS Wrapper.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Description of Vulnerability: \nAn issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users.\n\nAWS recommends that customers upgrade to the following version:  AWS NodeJS Wrapper to v2.0.1.\n\n### Source of Vulnerability Report:\nAllistair Ishmael Hakim [allistair.hakim@gmail.com](mailto:allistair.hakim@gmail.com)\n\n### Affected products \u0026 versions: \nAWS NodeJS Wrapper \u003c 2.0.1.\n\n### Platforms: \nMacOS/Windows/Linux","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"AWS Advanced NodeJS Wrapper: Privilege Escalation in Aurora PostgreSQL instance","id":"GHSA-8wj8-cfxr-9374","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"aws-advanced-nodejs-wrapper","purl":null,"source":"GHSA-8wj8-cfxr-9374"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"aws-advanced-nodejs-wrapper","purl":"pkg:npm/aws-advanced-nodejs-wrapper","source":"GHSA-8wj8-cfxr-9374"}],"products":null,"published":"2025-11-13","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A low-privilege user can escalate to rds_superuser role in Aurora PostgreSQL via a crafted function in the AWS NodeJS Wrapper.","url":"https://insights.sbomify.com/GHSA-8wj8-cfxr-9374/"}