{"answers":{"affected":"2 open source packages ship an affected version, including friendsofsymfony/user-bundle.","exploited":"There is no known exploitation of GHSA-8wx3-8m4x-g5h4 in the wild and no public exploit code.","fix":"Upgrade friendsofsymfony/user-bundle to 1.2.1 or later.","what":"GHSA-8wx3-8m4x-g5h4 is an authentication bypass vulnerability in friendsofsymfony/user-bundle, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8wx3-8m4x-g5h4 and fix it if it is affected.\n\nWhat it is: GHSA-8wx3-8m4x-g5h4 is an authentication bypass vulnerability in friendsofsymfony/user-bundle, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8wx3-8m4x-g5h4 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- friendsofsymfony/user-bundle (Packagist): affected from 1.0.0; fixed in 1.2.1\n- friendsofsymfony/user-bundle (Packagist): affected from 1.0.0; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8wx3-8m4x-g5h4/ (Markdown: https://insights.sbomify.com/GHSA-8wx3-8m4x-g5h4/index.md)","id":"GHSA-8wx3-8m4x-g5h4","markdown":"https://insights.sbomify.com/GHSA-8wx3-8m4x-g5h4/index.md","name":"GHSA-8wx3-8m4x-g5h4","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Symfony User Bundle","requires_auth":"low_privilege","summary":"An attacker can bypass identity validation if username changes are allowed, potentially leading to privilege escalation or unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Versions of FOSUserBundle prior to 1.2.1 have been found to be vulnerable to a security issue related to user identity validation. Specifically, user refreshing was performed using the primary key instead of the username, leading to a potential security risk if a user is allowed to change their username. The fix in version 1.2.1 addresses this issue by loading the user using the primary key during refreshing.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"FOSUserBundle User Identity Validation Vulnerability","id":"GHSA-8wx3-8m4x-g5h4","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["1.0.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":null,"source":"GHSA-8wx3-8m4x-g5h4"},{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["1.0.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":"pkg:composer/friendsofsymfony/user-bundle","source":"GHSA-8wx3-8m4x-g5h4"}],"products":null,"published":"2024-05-15","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can bypass identity validation if username changes are allowed, potentially leading to privilege escalation or unauthorized access.","url":"https://insights.sbomify.com/GHSA-8wx3-8m4x-g5h4/"}