GHSA-8xv9-qcr9-ww9j Authenticated XML External Entity Processing
Authenticated attackers can exploit XML External Entity processing to read sensitive data or cause denial of service in Shopware.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is GHSA-8xv9-qcr9-ww9j?
GHSA-8xv9-qcr9-ww9j is a vulnerability in shopware/core, published on 19 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Impact
Authenticated XML External Entity Processing
Patches
We recommend to update to the current version 6.3.2.1. You can get the update to 6.3.2.1 regularly via the Auto-Updater or directly via the download overview.
https://www.shopware.com/en/download/#shopware-6
Workarounds
For older versions of 6.1 and 6.2 the corresponding changes are also available via plugin: https://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659
For more information
https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-10-2020
Which versions are affected by GHSA-8xv9-qcr9-ww9j?
4 open source packages ship an affected version, including shopware/core and shopware/platform.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.3.2.1 |
shopware/core Packagist | All versions | 6.3.2.1 |
shopware/platform Packagist | All versions | 6.3.2.1 |
shopware/platform Packagist | All versions | 6.3.2.1 |
How do I fix GHSA-8xv9-qcr9-ww9j?
Upgrade shopware/core to 6.3.2.1 or later.
Is GHSA-8xv9-qcr9-ww9j being exploited?
There is no known exploitation of GHSA-8xv9-qcr9-ww9j in the wild and no public exploit code.