{"answers":{"affected":"4 open source packages ship an affected version, including shopware/core and shopware/platform.","exploited":"There is no known exploitation of GHSA-8xv9-qcr9-ww9j in the wild and no public exploit code.","fix":"Upgrade shopware/core to 6.3.2.1 or later.","what":"GHSA-8xv9-qcr9-ww9j is a vulnerability in shopware/core, published on 19 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-8xv9-qcr9-ww9j and fix it if it is affected.\n\nWhat it is: GHSA-8xv9-qcr9-ww9j is a vulnerability in shopware/core, published on 19 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-8xv9-qcr9-ww9j in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/core (Packagist): affected all versions; fixed in 6.3.2.1\n- shopware/core (Packagist): affected all versions; fixed in 6.3.2.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.2.1\n- shopware/platform (Packagist): affected all versions; fixed in 6.3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-8xv9-qcr9-ww9j/ (Markdown: https://insights.sbomify.com/GHSA-8xv9-qcr9-ww9j/index.md)","id":"GHSA-8xv9-qcr9-ww9j","markdown":"https://insights.sbomify.com/GHSA-8xv9-qcr9-ww9j/index.md","name":"GHSA-8xv9-qcr9-ww9j","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce platform","requires_auth":"low_privilege","summary":"Authenticated attackers can exploit XML External Entity processing to read sensitive data or cause denial of service in Shopware.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"### Impact\nAuthenticated XML External Entity Processing\n\n### Patches\nWe recommend to update to the current version 6.3.2.1. You can get the update to 6.3.2.1 regularly via the Auto-Updater or directly via the download overview.\n\nhttps://www.shopware.com/en/download/#shopware-6\n\n### Workarounds\nFor older versions of 6.1 and 6.2 the corresponding changes are also available via plugin:\nhttps://store.shopware.com/en/detail/index/sArticle/518463/number/Swag136939272659\n\n### For more information\nhttps://docs.shopware.com/en/shopware-6-en/security-updates/security-update-10-2020","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Authenticated XML External Entity Processing","id":"GHSA-8xv9-qcr9-ww9j","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2020"},"n_packages":4,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["6.3.2.1"],"introduced":["0"],"last_affected":[],"package":"shopware/core","purl":null,"source":"GHSA-8xv9-qcr9-ww9j"},{"ecosystem":"Packagist","fixed":["6.3.2.1"],"introduced":["0"],"last_affected":[],"package":"shopware/core","purl":"pkg:composer/shopware/core","source":"GHSA-8xv9-qcr9-ww9j"},{"ecosystem":"Packagist","fixed":["6.3.2.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":null,"source":"GHSA-8xv9-qcr9-ww9j"},{"ecosystem":"Packagist","fixed":["6.3.2.1"],"introduced":["0"],"last_affected":[],"package":"shopware/platform","purl":"pkg:composer/shopware/platform","source":"GHSA-8xv9-qcr9-ww9j"}],"products":null,"published":"2020-10-19","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Authenticated attackers can exploit XML External Entity processing to read sensitive data or cause denial of service in Shopware.","url":"https://insights.sbomify.com/GHSA-8xv9-qcr9-ww9j/"}