{"answers":{"affected":"2 open source packages ship an affected version, including leantime/leantime.","exploited":"There is no known exploitation of GHSA-92xh-6x7v-4rmq in the wild and no public exploit code.","fix":"Upgrade leantime/leantime to 3.1.2 or later.","what":"GHSA-92xh-6x7v-4rmq is a vulnerability in leantime/leantime, published on 21 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for GHSA-92xh-6x7v-4rmq and fix it if it is affected.\n\nWhat it is: GHSA-92xh-6x7v-4rmq is a vulnerability in leantime/leantime, published on 21 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of GHSA-92xh-6x7v-4rmq in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- leantime/leantime (Packagist): affected all versions; fixed in 3.1.2\n- leantime/leantime (Packagist): affected all versions; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-92xh-6x7v-4rmq/ (Markdown: https://insights.sbomify.com/GHSA-92xh-6x7v-4rmq/index.md)","id":"GHSA-92xh-6x7v-4rmq","markdown":"https://insights.sbomify.com/GHSA-92xh-6x7v-4rmq/index.md","name":"GHSA-92xh-6x7v-4rmq","record":{"aliases":[],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Leantime project management","requires_auth":"high_privilege","summary":"A CSRF vulnerability allows attackers to create high-privilege accounts by tricking administrators into clicking a malicious link.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"**CSRF**\n### Summary\nA cross-site request forgery vulnerability allows a remote actor to create an account with Owner privileges. By luring an Owner or Administrator into clicking a button on an attacker-controlled website, a request will be issued, generating an account with the attacker's information and role of their choosing. \n\n### Impact\nWhile the likelihood of a successful exploit is low, the impact would be high as the attacker could then gain complete control over the victim's environment.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Leantime allows Cross-Site Request Forgery (CSRF)","id":"GHSA-92xh-6x7v-4rmq","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"leantime/leantime","purl":null,"source":"GHSA-92xh-6x7v-4rmq"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"leantime/leantime","purl":"pkg:composer/leantime/leantime","source":"GHSA-92xh-6x7v-4rmq"}],"products":null,"published":"2025-02-21","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"A CSRF vulnerability allows attackers to create high-privilege accounts by tricking administrators into clicking a malicious link.","url":"https://insights.sbomify.com/GHSA-92xh-6x7v-4rmq/"}