GHSA-93qj-5q5v-3c2h Trojanized pantheon-agents 0.6.1 and 0.6.2 on PyPI ship a credential stealer (supply-chain account compromise)

Not scored Published

Trojanized PyPI releases of pantheon-agents execute a credential stealer, exposing all host credentials to attackers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is GHSA-93qj-5q5v-3c2h?

GHSA-93qj-5q5v-3c2h is a vulnerability in pantheon-agents, published on 26 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Summary

The PyPI account that publishes pantheon-agents was compromised in the June 2026 "Hades" PyPI supply-chain attack (Mini Shai-Hulud / Miasma lineage). The attacker used a stolen, long-lived PyPI API token to upload trojanized releases pantheon-agents 0.6.1 and 0.6.2 directly to PyPI.

Only the PyPI artifacts are affected. The GitHub source repository, its git tags, and all other distribution channels are clean — no malicious code was committed to the repository.

Affected

  • pantheon-agents 0.6.1 and 0.6.2 on PyPI.

Not affected: installs from the GitHub source, version 0.6.0 and earlier, and the Desktop / Online apps.

Indicators of compromise

The malicious wheels ship a *-setup.pth file that executes on Python startup. It downloads the Bun JavaScript runtime and runs an obfuscated credential stealer (_index.js) that harvests and exfiltrates credentials reachable from the host — environment variables, ~/.pypirc, ~/.npmrc, cloud credentials (~/.aws, etc.), SSH keys, and API tokens.

Check your environment's site-packages for an unexpected *-setup.pth, and your home directory for _index.js or a Bun runtime (~/.bun).

Impact

Anyone who pip installed pantheon-agents 0.6.1 or 0.6.2 should assume every credential present on that machine has been exfiltrated.

Remediation

  1. Do not install pantheon-agents from PyPI until distribution resumes.
  2. If you installed 0.6.1 or 0.6.2:
    • Run pip uninstall pantheon-agents immediately and check for the IoCs above.
    • Rotate every credential that was present on that machine (API keys, tokens, SSH keys, cloud credentials).
  3. Install only from the clean GitHub source:
    pip install "git+https://github.com/aristoteleo/PantheonOS.git"
    

Status

The PyPI account is suspended and the malicious token has been disabled. PyPI distribution will resume after account recovery and migration to PyPI Trusted Publishing (OIDC). Sibling projects by the same maintainer (e.g. executor-engine, funcdesc, cmd2func, pantheon-toolsets, coolbox, ufish, magique, executor-http) were hit by the same campaign and are being remediated separately.

Which versions are affected by GHSA-93qj-5q5v-3c2h?

2 open source packages ship an affected version, including pantheon-agents.

PackageAffectedFixed in
pantheon-agents PyPIFrom 0.6.10.6.4
pantheon-agents PyPIFrom 0.6.10.6.4

How do I fix GHSA-93qj-5q5v-3c2h?

Upgrade pantheon-agents to 0.6.4 or later.

Is GHSA-93qj-5q5v-3c2h being exploited?

There is no known exploitation of GHSA-93qj-5q5v-3c2h in the wild and no public exploit code.

Sources

Is GHSA-93qj-5q5v-3c2h in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free