# GHSA-93qj-5q5v-3c2h: Trojanized pantheon-agents 0.6.1 and 0.6.2 on PyPI ship a credential stealer (supply-chain account compromise)

> Trojanized PyPI releases of pantheon-agents execute a credential stealer, exposing all host credentials to attackers.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2026

## What is GHSA-93qj-5q5v-3c2h?

GHSA-93qj-5q5v-3c2h is a vulnerability in pantheon-agents, published on 26 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

## Summary
The PyPI account that publishes `pantheon-agents` was compromised in the June 2026 "Hades" PyPI supply-chain attack (Mini Shai-Hulud / Miasma lineage). The attacker used a stolen, long-lived PyPI API token to upload **trojanized releases `pantheon-agents` 0.6.1 and 0.6.2 directly to PyPI**.

**Only the PyPI artifacts are affected.** The GitHub source repository, its git tags, and all other distribution channels are clean — no malicious code was committed to the repository.

## Affected
- `pantheon-agents` **0.6.1** and **0.6.2** on PyPI.

Not affected: installs from the GitHub source, version 0.6.0 and earlier, and the Desktop / Online apps.

## Indicators of compromise
The malicious wheels ship a `*-setup.pth` file that executes on Python startup. It downloads the Bun JavaScript runtime and runs an obfuscated credential stealer (`_index.js`) that harvests and exfiltrates credentials reachable from the host — environment variables, `~/.pypirc`, `~/.npmrc`, cloud credentials (`~/.aws`, etc.), SSH keys, and API tokens.

Check your environment's `site-packages` for an unexpected `*-setup.pth`, and your home directory for `_index.js` or a Bun runtime (`~/.bun`).

## Impact
Anyone who `pip install`ed `pantheon-agents` 0.6.1 or 0.6.2 should assume **every credential present on that machine has been exfiltrated.**

## Remediation
1. **Do not install `pantheon-agents` from PyPI** until distribution resumes.
2. If you installed 0.6.1 or 0.6.2:
   - Run `pip uninstall pantheon-agents` immediately and check for the IoCs above.
   - **Rotate every credential** that was present on that machine (API keys, tokens, SSH keys, cloud credentials).
3. Install only from the clean GitHub source:
   ```
   pip install "git+https://github.com/aristoteleo/PantheonOS.git"
   ```

## Status
The PyPI account is suspended and the malicious token has been disabled. PyPI distribution will resume after account recovery and migration to PyPI Trusted Publishing (OIDC). Sibling projects by the same maintainer (e.g. executor-engine, funcdesc, cmd2func, pantheon-toolsets, coolbox, ufish, magique, executor-http) were hit by the same campaign and are being remediated separately.

## Which versions are affected by GHSA-93qj-5q5v-3c2h?

2 open source packages ship an affected version, including pantheon-agents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pantheon-agents` | PyPI | From 0.6.1 | 0.6.4 |
| `pantheon-agents` | PyPI | From 0.6.1 | 0.6.4 |

## How do I fix GHSA-93qj-5q5v-3c2h?

Upgrade pantheon-agents to 0.6.4 or later.

## Is GHSA-93qj-5q5v-3c2h being exploited?

There is no known exploitation of GHSA-93qj-5q5v-3c2h in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-93qj-5q5v-3c2h and fix it if it is affected.

What it is: GHSA-93qj-5q5v-3c2h is a vulnerability in pantheon-agents, published on 26 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of GHSA-93qj-5q5v-3c2h in the wild and no public exploit code.

Affected packages and fixed versions:
- pantheon-agents (PyPI): affected from 0.6.1; fixed in 0.6.4
- pantheon-agents (PyPI): affected from 0.6.1; fixed in 0.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-93qj-5q5v-3c2h/ (Markdown: https://insights.sbomify.com/GHSA-93qj-5q5v-3c2h/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-93qj-5q5v-3c2h

---
From sbomify Insights: https://insights.sbomify.com/GHSA-93qj-5q5v-3c2h/
Summaries are generated and may contain mistakes; the official description above is the record.
