{"answers":{"affected":"2 open source packages ship an affected version, including openclaw.","exploited":"There is no known exploitation of GHSA-943q-mwmv-hhvh in the wild and no public exploit code.","fix":"Upgrade openclaw to 2026.2.14 or later.","what":"GHSA-943q-mwmv-hhvh is a vulnerability in openclaw, published on 2 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-943q-mwmv-hhvh and fix it if it is affected.\n\nWhat it is: GHSA-943q-mwmv-hhvh is a vulnerability in openclaw, published on 2 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-943q-mwmv-hhvh in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openclaw (npm): affected all versions; fixed in 2026.2.14\n- openclaw (npm): affected all versions; fixed in 2026.2.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/ (Markdown: https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/index.md)","id":"GHSA-943q-mwmv-hhvh","markdown":"https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/index.md","name":"GHSA-943q-mwmv-hhvh","record":{"aliases":[],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenClaw Gateway","requires_auth":"low_privilege","summary":"Authenticated attackers can escalate privileges to execute commands and control sessions via exposed gateway endpoints and auto-approved permissions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"## Summary\n\nOpenClaw Gateway exposes an authenticated HTTP endpoint (`POST /tools/invoke`) intended for invoking a constrained set of tools. Two issues could combine to significantly increase blast radius in misconfigured or exposed deployments:\n\n- The HTTP gateway layer did not deny high-risk session orchestration tools by default, allowing a caller with Gateway auth to invoke tools like `sessions_spawn` / `sessions_send` and pivot into creating or controlling agent sessions.\n- ACP clients could auto-approve permission requests for risky tools with insufficient user interaction/guardrails, reducing the friction that should normally prevent silent execution or mutation.\n\n## Impact\n\nIf the Gateway is reachable by an attacker and they obtain a valid Gateway token, they may be able to:\n\n- Escalate from single-tool invocation to spawning/controlling sessions and reach command execution capabilities depending on tool policy and runtime environment.\n- Perform cross-session message injection via `sessions_send`.\n- In ACP-integrated scenarios, obtain unintended approvals for non-read/search tool permissions.\n\n## CVSS\n\n- `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H` (8.8)\n\n## Affected versions\n\n- `openclaw \u003c 2026.2.14`\n\n## Fixed in\n\n- `openclaw \u003e= 2026.2.14`\n\n## Remediation\n\nThe default behavior is now hardened:\n\n- PR #15390: deny high-risk tools over HTTP `/tools/invoke` by default (with `gateway.tools.{allow,deny}` overrides) and harden ACP permission handling.\n- Commit `bb1c3dfe1`: ACP clients now prompt for any non-read/search permission request (fail closed for mutating/execution/fetch operations).\n- Commit `539689a2f`: security audit warns when `gateway.tools.allow` re-enables default-denied HTTP tools, since this can increase RCE blast radius if the Gateway is reachable.\n- Commit `153a7644e`: ACP safe-kind inference is stricter to avoid accidental auto-approval due to substring matches (still auto-approves only confident `read/search`).\n\n## Mitigations / deployment guidance\n\n- Keep the Gateway loopback-only unless you have a strong reason not to: `gateway.bind=\"loopback\"` / `openclaw gateway run --bind loopback`.\n- Avoid exposing the Gateway directly to the public internet. Use an SSH tunnel or Tailscale to access a loopback-bound Gateway.\n- Treat opting in to default-denied HTTP tools (via `gateway.tools.allow`) as high-risk and audit such configurations carefully.\n\n## Credits\n\nOpenClaw thanks @aether-ai-agent for reporting this issue and contributing remediation work.","ecosystems":["npm"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"OpenClaw: Gateway /tools/invoke tool escalation + ACP permission auto-approval","id":"GHSA-943q-mwmv-hhvh","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"npm","fixed":["2026.2.14"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":null,"source":"GHSA-943q-mwmv-hhvh"},{"ecosystem":"npm","fixed":["2026.2.14"],"introduced":["0"],"last_affected":[],"package":"openclaw","purl":"pkg:npm/openclaw","source":"GHSA-943q-mwmv-hhvh"}],"products":null,"published":"2026-03-02","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Authenticated attackers can escalate privileges to execute commands and control sessions via exposed gateway endpoints and auto-approved permissions.","url":"https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/"}