# GHSA-943q-mwmv-hhvh: OpenClaw: Gateway /tools/invoke tool escalation + ACP permission auto-approval

> Authenticated attackers can escalate privileges to execute commands and control sessions via exposed gateway endpoints and auto-approved permissions.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Mar 2026

## What is GHSA-943q-mwmv-hhvh?

GHSA-943q-mwmv-hhvh is a vulnerability in openclaw, published on 2 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

## Summary

OpenClaw Gateway exposes an authenticated HTTP endpoint (`POST /tools/invoke`) intended for invoking a constrained set of tools. Two issues could combine to significantly increase blast radius in misconfigured or exposed deployments:

- The HTTP gateway layer did not deny high-risk session orchestration tools by default, allowing a caller with Gateway auth to invoke tools like `sessions_spawn` / `sessions_send` and pivot into creating or controlling agent sessions.
- ACP clients could auto-approve permission requests for risky tools with insufficient user interaction/guardrails, reducing the friction that should normally prevent silent execution or mutation.

## Impact

If the Gateway is reachable by an attacker and they obtain a valid Gateway token, they may be able to:

- Escalate from single-tool invocation to spawning/controlling sessions and reach command execution capabilities depending on tool policy and runtime environment.
- Perform cross-session message injection via `sessions_send`.
- In ACP-integrated scenarios, obtain unintended approvals for non-read/search tool permissions.

## CVSS

- `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H` (8.8)

## Affected versions

- `openclaw < 2026.2.14`

## Fixed in

- `openclaw >= 2026.2.14`

## Remediation

The default behavior is now hardened:

- PR #15390: deny high-risk tools over HTTP `/tools/invoke` by default (with `gateway.tools.{allow,deny}` overrides) and harden ACP permission handling.
- Commit `bb1c3dfe1`: ACP clients now prompt for any non-read/search permission request (fail closed for mutating/execution/fetch operations).
- Commit `539689a2f`: security audit warns when `gateway.tools.allow` re-enables default-denied HTTP tools, since this can increase RCE blast radius if the Gateway is reachable.
- Commit `153a7644e`: ACP safe-kind inference is stricter to avoid accidental auto-approval due to substring matches (still auto-approves only confident `read/search`).

## Mitigations / deployment guidance

- Keep the Gateway loopback-only unless you have a strong reason not to: `gateway.bind="loopback"` / `openclaw gateway run --bind loopback`.
- Avoid exposing the Gateway directly to the public internet. Use an SSH tunnel or Tailscale to access a loopback-bound Gateway.
- Treat opting in to default-denied HTTP tools (via `gateway.tools.allow`) as high-risk and audit such configurations carefully.

## Credits

OpenClaw thanks @aether-ai-agent for reporting this issue and contributing remediation work.

## Which versions are affected by GHSA-943q-mwmv-hhvh?

2 open source packages ship an affected version, including openclaw.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.14 |
| `openclaw` | npm | All versions | 2026.2.14 |

## How do I fix GHSA-943q-mwmv-hhvh?

Upgrade openclaw to 2026.2.14 or later.

## Is GHSA-943q-mwmv-hhvh being exploited?

There is no known exploitation of GHSA-943q-mwmv-hhvh in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-943q-mwmv-hhvh and fix it if it is affected.

What it is: GHSA-943q-mwmv-hhvh is a vulnerability in openclaw, published on 2 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of GHSA-943q-mwmv-hhvh in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.14
- openclaw (npm): affected all versions; fixed in 2026.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/ (Markdown: https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-943q-mwmv-hhvh

---
From sbomify Insights: https://insights.sbomify.com/GHSA-943q-mwmv-hhvh/
Summaries are generated and may contain mistakes; the official description above is the record.
